Disconnecting Since Firmware Update v04.00.00-607

Before the release of firmware update v04.00.00-607 my 3TB cloud device never lost connection to my home network. Two days after the auto-update in early July, it lost connection for the first time.  The new firmware did exactly the opposite to my device that it did for everyone else having connection problems.  Last Sunday I tried to “revert” to an older version, but it would not work.  I then downloaded and re-installed v04.00.00-607.  It did set a new record of 4 days before the connection was lost after the reinstall, but yesterday I lost the connection again.  

All the lights on the device are what they are supposed to be, in particular solid blue in front.  

I have to unplug the device from the power and I have started also unplugging the cord to the router, as I read in the manual, I think.  I then reconnect and after it boots, everything works just fine.  Anyhow, 1, 2, 3 or more days later, it disconnects again.  The computer upstairs that is hardwired to the router loses connection, too.  I know it is not the router. 

I used to be able to connect using the wife’s tablet from half way across the country.  Now we can’t connect from five feet away. 

I’ve already made certain I have all software updates installed.  Can someone please help?  Why did the new firmware break my cloud device?

 Thanks in advance.

good stuff huh?   try reverting again.   Or even try the reset button on the back of the unit. 

Been there, done that.  

Thanks for trying.

Maybe I don’t have the firmware before .607.  The one I found, not easily, is sq-030401-230-20140415.deb

I have had alot of problems with disconnecting as well, tried all the suggested fixes, what finally worked for me was turning off remote cloud access. It seems that even though I only streamed through lan, it somehow interfered, when streaming movies it would randomly disonnect every 30 min or so, haven’t had any problems since watching several movies…

Obviously this fix is no good if you need to use the remote access, but for home use it’s done the job for me… Worth a try.

Sadly turning off remote access is not an option for us.  My computer is connected wirelessly, one upstairs is hardwired to router.  When the device disconnects, it cannot be accessed via the hardwired computer, either.  The device is plugged into the same router and the lights on the device are the right colors and so forth, so I do not understand it.  If only I could go back to the firmware before 607, but it won’t let me.  

I tried plugging it into my computer via the ethernet port to be accessed wirelessly from the hardwired computer, but I never figured out how to get the other computer or the tablet to talk to it.

After  much reading of similar problems and “fixes,” I learned I should do a search in the forum for downgrading the firmware (because it would fail when I tried it previously).  After adding “windows” to my search query, I found:

" Easy method to downgrade to previous version of the firmware"

It took about 45 minutes, including download and installation of the software to edit a file on the device to make it think it had an older version of firmware, rebooting, manually installing the older version of the firmware, rebooting, and then, finally, rebooting my computer because WD Quick View did not show the device.  

Worked like a champ.  So, today is day 0 and counting to see if it disconnects in the future.  I am keeping my fingers crossed.  If it does disconnect, I’ll post a message.

Just make certain automatic firmware updates are off and that you ignore warnings to update your firmware.  Maybe there will be a version 501 soon to fix 401. 

FYI, the remote cloud access is to access the device from the internet, it has nothing to do with devices on your local wifi network. I have not had any issues with this but if you don’t use remote access it is not needed

I’m not certain what you are telling me.  

We could not access the cloud from the Web on the tablet when out of town, nor could we access it even from the computer hard-wired to the router whenever it disconnected.  My computer is wirelessly connected.  Before the release of the latest firmware, there were no problems out of town or at home.

But now I have gone back to the earlier firmware and everything works as it should…  at least so far.  And it is much faster than I remembered, too, as it has been since July it has been disconnecting.