Disable password access to MyBook2

I have MyBook2 World Ed. (white lights) on a Win7 network.

I recently setup a new laptop, including access to the MyBook. I don’t why, but now whenever I want to access the MyBook, I have to first enter a username and password, which I never had to do before.

I want to disable the password protect. (I’m not worried about the security issues.)

Before answering  that it’s impossible to do, please consider that I’ve never had to use a password to access until now.

Hi there, what if you reset it?

The admin password resets, but the user password doesn’t. I deleted the user, but password still required when I access through Windowss Explorer.

Did you create this folder or was this one of the public folders?

If this is a public folder and you are asked to enter credentials most likely is because your computer is cashing credentials from other connections.(other mapped drives) or other kind of network connections that have been previewsly stablished. 

Try createing another folder and make sure to make it public then try accessing it again. Just a thought

It’s a folder I created.

Almost the same problem here. But under windows XP.

If I want to connect it asks for a user / password.

If I enter admin as user, which has no password, access is denied.

This doesn’t seem like it should be a difficult problem to solve.

Does anyone know whether the WD firmware requires a password for access?

If so, is it configurable? How? Can it be disabled?

If not it’s not part of the firmware, then this would be a Windows problem, right?

Anyone from WD??

I discovered that if I delete all users except Admin I am able to connect to the driver without user / password.

However, FTP access via Admin is disallowed. With or without password set.

Mind you further that after making these change you have to reboot the drive and windows.

Windows remembers credentials being given until reboot.

Update :

I have discoverd what caused the problems. To get FTP access I have to define a seperate user / password.

It is not allowed to use the admin account. However, if that new user is equal to the windows account, somehow things get messed up and windows will ask for credentials when you try to access the drive via explorer.

By using a different non windows account I am able to

  • Access the drive via explorer without a user / password (I suppose guest is used then as account)

  • Access the drive via FTP with credentials user / password

Thats is exact the way I want it to behave :smiley: