/dev/md1 100% full

Hi All,

Need your help to fix MBL 3TB NAS drive. I am able to stream movies and songs to TV and even on laptop perfectly but today when i tried to login via /UI/login i couldnt login even when my password was correct.

Later i tried to search all the thread about the issue and than logged in using putty through ssh and was able to login with root user. I later tried to change password of admin user but i was not able to do. Further invesigating i discovered that my /dev/md1  is 100% full. Below are my file system 

XXXXXX:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/md1 1.9G 1.9G 0 100% /
tmpfs 50M 0 50M 0% /lib/init/rw
udev 10M 6.7M 3.4M 67% /dev
tmpfs 50M 0 50M 0% /dev/shm
tmpfs 50M 9.9M 41M 20% /tmp
ramlog-tmpfs 20M 4.4M 16M 22% /var/log
/dev/sda4 2.8T 611G 2.2T 22% /DataVolume

I have already moved file daemon.log and daemon.log.1 to /DataVolume and still the /dev/md1 is 100% full. :frowning:

I also edited dynamicconfig.ini_safe as below

SUBDOMAIN=""
DEVICEID=“XXXXX”
DEVICEAUTH=“REMOVEDXXXFORXXXSECURITY”
EXTERNAL_IP=“REMOVED”
EXTERNAL_PORT=“80”
EXTERNAL_SSL_PORT=“443”
INTERNAL_IP=“REMOVED”
INTERNAL_PORT=“80”
DEVICE_SSL_PORT=“443”
REMOTEACCESS=“TRUE”
COMMUNICATION_STATUS=“portforwarded”
DEFAULT_PORTS_ONLY=“FALSE”
MANUAL_PORT_FORWARD=“FALSE”
MANUAL_EXTERNAL_ROUTER_IP=""
MANUAL_EXTERNAL_HTTP_PORT=“80”
MANUAL_EXTERNAL_HTTPS_PORT=“443”
TOTAL_SETTINGS=“17”

I did not restart the nas drive but i did try to login again and still not accepting my admin password through /UI/login

I remember i did upgrade the firmware in the month of december.

What would be the rootcause of this issue and how should i get the /UI/Login working back to normal like before.

If i do a reset of my hard disk will i loose any data?

Please help

Ritesh

You can try pressing the reset button on the back size for 4 seconds and that will not delete your files. 

I did try to reset my NAS drive but still the file system shows 100% full for /dev/md1

XXXXXX~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/md1 1.9G 1.9G 0 100% /
tmpfs 50M 0 50M 0% /lib/init/rw
udev 10M 6.7M 3.4M 67% /dev
tmpfs 50M 0 50M 0% /dev/shm
tmpfs 50M 4.2M 46M 9% /tmp
ramlog-tmpfs 20M 4.2M 16M 21% /var/log
/dev/sda4 2.8T 613G 2.2T 23% /DataVolume

You need to find out which folder is eating up all your space. Run these commands in PuTTY and it will give you a list from smallest to largest and compare to mine. If something is way off, browse that folder in WinSCP and see if there are any odd files in that folder

login as: rootroot@192.168.1.6's password:Linux MYBOOKLIVE 2.6.32.11-svn52288 #1 Wed Oct 26 18:57:59 PDT 2011 ppcThe programs included with the Debian GNU/Linux system are free software;the exact distribution terms for each program are described in theindividual files in /usr/share/doc/*/copyright.Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extentpermitted by applicable law.Disclaimer: SSH provides access to the network device and all itscontent, only users with advanced computer networking and Linux experienceshould enable it. Failure to understand the Linux command line interfacecan result in rendering your network device inoperable, as well as allowingunauthorized users access to your network. If you enable SSH, do not sharethe root password with anyone you do not want to have direct access to allthe content on your network device.MYBOOKLIVE:~# cd ..MYBOOKLIVE:/# du -ks ./* | sort -ndu: cannot access `./proc/8560/task/8560/fd/4': No such file or directorydu: cannot access `./proc/8560/task/8560/fdinfo/4': No such file or directorydu: cannot access `./proc/8560/fd/4': No such file or directorydu: cannot access `./proc/8560/fdinfo/4': No such file or directory0       ./proc0       ./sys4       ./24       ./debootstrap4       ./media4       ./opt4       ./selinux4       ./srv12      ./home16      ./lost+found36      ./root2816    ./CacheVolume3328    ./tmp5016    ./etc5028    ./bin6720    ./dev7340    ./boot7840    ./sbin17560   ./lib40788   ./var351764  ./usr852907264       ./nfs852907264       ./shares852910336       ./DataVolumeMYBOOKLIVE:/#

 Here is my filesystem usage

MYBOOKLIVE:~# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/md1 1.9G 458M 1.4G 26% /
tmpfs 50M 0 50M 0% /lib/init/rw
udev 10M 6.6M 3.5M 66% /dev
tmpfs 50M 0 50M 0% /dev/shm
tmpfs 50M 3.3M 47M 7% /tmp
ramlog-tmpfs 20M 2.4M 18M 12% /var/log
/dev/sda4 924G 816G 109G 89% /DataVolume

I have the same issue. Any ideas how to fix it?

Uhm, did you read the post right before yours?

Hi Tony,

I found a folder /var/www/Software which contains smartware, user manual, etc. Do you think I can just took them out?

Thanks,

/var/www/Software?

I can’t imagine what anything would be doing in there…

My /var/www/Software folder is empty.

I would guess it’s safe to remove… 

1 Like

Great! I don’t know why but there are smartwares, user manual and the date of the folder is 1970!. Weird.

Yea… I just noticed this.  My original Smartware share was actually empty.  I think it was used for backups by the WD software so I just removed the share but I see the files in my /var/www/Software as well.  Interestingly enough the Windows setup installers are missing. lol.  I’m going to delete them sicne they are probably not needed. :stuck_out_tongue: