Deleting time machine?


#1

When I first got this I put a time machine backup on it.  Now I don’t want the backup, but want all that space back.  How do I delete time machine completely off the My Book and free up some space?  Do I just drag the Backups.backupdb folder into the trash and delete?


#2

Make sure you go into Time Machine and turn it off first.  Then you can just reformat the drive, which is the best thing to do.  Unless, of course, you have other data on the drive, which you shouldn’t if you’ve been running Time Machine.  However, if you have other data on the drive, make sure you copy it off the drive first, and then reformat.


#3

I have several terabites of other data on the My Book NAS.  Reformatting or moving things isn’t an option.  I just want to delete the time machine.


#4

Then, make sure to turn off Time Machine and then delete the folder off the drive.  You were not supposed to use Time Machine this way, with other data being copied to the drive, so I don’t know how the drive will eventually act.  I would recommend contacting Apple to make sure that your data will be okay. 


#5

Thanks, but what do you mean I was not supposed to use Time Machine this way?  Why does it have to be used some special perfect way?  Should just be simple to delete if you don’t want it anymore.  I have a 4tb My Book NAS, was I supposed to dedicate it entirely to just a time machine?  I followed the directions exactly on the insert that came with the My Book.


#6

That’s just how I understand it.  You should really ask someone from the Apple store, or Apple’s support site, about how Time Machine works.


#7

I tried deleting the time machine, all the files are gone and it looks deleted, but the space is not freed up.  How do I reclaim  the free space? Apple isn’t any help.  The My Book is obviously not properly compatible with the Time Machine and it shouldn’t be advertised as such, I’ve all but given up.  I have about half a TB just sitting there on the drive empty now with no way to access it.


#8

OK, solved this now, thankfully.  Logging in as root and using some terminal commands I managed to finally get the space back.  Following basically the method described here. http://www.oak-tree.us/blog/index.php/2009/10/18/time-machine-reclaim-space.  The Lesson learned, don’t put a Time Machine on your NAS unless you’re serious about a lifetime commitment.


#9

The quickest way of reclaiming timemachine space is:

Enable SSH login in western digital

login to the disk like:

ssh -l root {ip of your disk}

and carefully execute this command:

rm -rf /DataVolume/.timemachine

All your timemachine related data is removed.

Greeting