Dead 4TB WD hard drive, can't get RMA started

When I try to create RMA, it needs address and once I click submit, nothing happens. The page seems eternally stuck on submitting and when I mouse over the submit button, I got a red circle with a diagonal line.

I have tried on Firefox and Edge and both hangs at the same page. I am unable to get past that step and get the RMA created so I can ship the hard drive back. I have tried restarting browser and clearing cache, every time I get to address creation page and click submit it just hangs. It’s like somewhere, something forgot how to handle address data and store it in WD server. Or maybe your server needs a new hamster?

This screenshot shows what it looks like on Edge browser after about 10 minutes of waiting: (info blacked out)

I can’t return this drive to Walmart as it had been too long (over 3 months) and it’s still got many more years of warranty left.

Update: got a reply in support, responded with my name and address. Waiting for shipping info to send the dead drive.