Dead 1TB MyBook Elite?

My 1TB MyBook Elite (about 1.5 yrs old) seems to have died.

Symptoms as follows:

If I leave the drive plugged in and powered, booting my computer (WinXP SP3) hangs after the Windows splash screen.  Unplugging or powering down the external hard drive allows the computer to continue booting.

Display on the MB just says “SMARTDRIVE”  The capacity gauge, lock light, etc. are all missing.

After the computer is running, if I plug in the MB, it’ll sit there for a while and then eventually the F: drive (VCD) appears.  However, my data partition (G: drive) is non-existent.  If I run the Smartware application, it will hang.

A review of the system logs reveals various Delayed Write Failed and bad block messages.

The G: drive doesn’t show up in Windows Disk Manager.

I’ve swapped cables, plugged directly into the wall, etc.  to no effect.

If I run TestDisk, it finds the C: drive, the DVD drive, and both the MyBook VCD and G: drive partitions and identifies the G: drive as a primary bootable partition.  However, I can’t save the partition table even if I wanted to since rebooting with the external drive connected hangs.

I’ve yet to try and run HDDScan.  In addition, I’m also considering whether or not I should try and update the firmware and smartware versions.

This looks mostly to me like a problem with the drive enclosure and not the drive itself.

I suspect that I’ll be unsuccessful regardless and that the drive is dead.

Any suggestions?

Since the VCD can still show up, then try a firmware update. This was a common problem with older Smartware drives.

I’m torn between updating the firmware and buying another new/used 1TB My Book Elite and swapping my current drive into a good enclosure to see if I can recover the data.  If I attempt to update the firmware and it doesn’t work, will it prevent me from putting the drive into a new enclosure later?

EDIT:  applied a firmware update.  It went through and indicated that the update was successful.  Closed out the firmware updater, disconnected USB and power cycled, then reconnected per directions and then rebooted.

No dice - the drive is still inaccessible.  However, I notice that after I plug in the drive and the VCD drive shows up, if I disconnect the drive, for a split second, the missing partition appears as “F: Local Drive” before vanishing.

I’m trying to use UFSExplorer - so far it appears to be working, but looks like it’ll be a several hour process before I can figure out whether or not I can recover anything.

Not going to work, the MB Elite is hardware-envrypted via the logic board, it has been documented and reported several times in here that it can’t be done.


UFSExplorer was able to reveal the partition, directory/file structure, and the various files (I’ve yet to try and actually copy from the drive to another location).  In addition, while I let it run overnight to try to recover things, the drive mysteriously “appeared” in Windows Explorer, albeit as “F: Local Drive”.

So - is this to be expected?  That UFSExplorer will find the directory structure, but if the drive isn’t showing up normally in windows, then I won’t be able to retrieve them?

This is very strange - the drive doesn’t show up initally, but does so eventually.  I can’t actually access it, but TestDisk can find the partition and UFSExplorer reveals the directory/file structure.

I’m assuming these are symptoms of a bad bridge board - in which case I’ve gotta find another MyBook Elite and swap the drive?