DataLifeGuard diagnostic: Unable to locate license agreement file dlglice.txt


#1

Hi,

i’m trying to use the data life guard boot CD to test some wdc dirves, but the tool never starts and i receive the following message: Unable to locate license agreement file dlglice.txt.

I’m using an Asus p6td deluxe motherboard and wdc drives are connected to ich10 sata ports. The dvd drive is a sata Liteon.

what can i do ? Have anyone of you had a similar experience ?

Thanks in advance!


#2

I have the same problem.  Program did not ask for license.

hope we get an answer


#3

I contacted the email technical support but the only suggestion they gave me is to use the windows version of dlgdiag tool. They also said me the datalifeguard is the only way to obtain an RMA in case of problem!

Unfortunatly i haven’t a windows license available and i’m not going to buy a licence only to run thier diagnostic tool.

After several email they told me that the case was escalated to a laboratory and that my case was the only one they have never heard about this specific problem. So if you have some time to spend I suggest to contact them and supply as mach details as you can.


#4

jjletho wrote:

I contacted the email technical support but the only suggestion they gave me is to use the windows version of dlgdiag tool. They also said me the datalifeguard is the only way to obtain an RMA in case of problem!

Unfortunatly i haven’t a windows license available and i’m not going to buy a licence only to run thier diagnostic tool.

 

DLG Diagnostics has nothing to do with being able to get an RMA if you need one.  What he might have been referring to is being able to get the serial number for the drive - which is essential to getting an RMA - using the DLG Diagnostic utility.  If you can read the serial number correctly off the label of the drive, you can get an RMA if the drive is under warranty.


#5

Thank you for the clarification Bill_S, this makes more sense!

In the meanwhile I downloaded the s.c. “Ultimate boot cd” from this site http://www.ultimatebootcd.com/.

This bootable cd is a colletion of hardware related (and freeware) tools and includes also the latest version of dlgdiag. From this cd I was able to boot and run dlgdiag.exe!

I suppose the problem with the WD boot cd is in the boot environment (old driver for example).

Waiting for a soluton from wd lab this could be a good  alternative.


#6

Good.  I’m glad to hear that you found something to work for you.  


#7

I’ve found the same issue described in this post. The Datalife guard cd image doesn’t work properly. The boot stops with the same error about the licence file even if the file is located in the same root directory of the exe. Now i’m downloading the ubcd from the link above and i hope to solve the problem. 

Googling i’ve found many other users with this problem, i hope WD Technicians try to solve this problem. Actually the boot cd in most cases is the only way to diagnostic a harddisk failure …


#8

I have an HP Pavilion 8408us laptop with 2 hard drive bays.  Originally, I only had one hard drive in it - an 80gig Seagate SATA drive running WinXP Media Center Edition (a variation of WinXP Pro).  The OS came with the laptop preinstalled - along with a whole lot of bloatware I didn’t like.  So, I decided to take the plunge.  I bought two new Western Digital SATA drives - one 500gig, one 250gig.  I bought a WinXP Pro SP3 OEM disk and planned to install it on the 500gig drive with Ubuntu (Linux) installed on the 250gig drive.

Then came this DataLifeGuard problem that a lot of people all over the web (not just here) seem to be talking about.  I have the same problem.  And, when I tried the Ultimate Boot CD, it reaches a certain point and just stops dead in its tracks … with no visible hard drive activity at all.  And of course, when I put in the WinXP Pro CD and try to install, it says it can’t locate any hard drives.  Note that I attempted to use both DataLifeGuard and UBCD CDs with both hard drives installed and with only one hard drive installed.  Same results.

But, here’s where it gets interesting (grin).  WinXP Pro’s installation disk says it can’t find hard drives.  But Ubuntu’s installation disk found both.  As we speak, I am communicating on my laptop with Ubuntu’s Firefox … running the OS off my 250gig “un-prepared” hard disk.  And Ubuntu did tests on both hard disks and found them healthy.

I have a theory, a request, and a final comment:

  1. Theory - The very last thing you see when the DataLifeguard CD fails is that it can’t find:

A:\COMMAND.COM

Take a look at the dates of the files on the DataLifeguard CD.   Three files were last modified in 2005 - and two files (the “COM” files that run the show) haven’t been modified since 2000 - which is before even WinXP came out!!!  Back in 2000, almost every computer had a 3.5" floppy drive.  Nowadays, most computers (like my laptop) don’t.  Could someone at Western Digital “reverse-compile” DataLifeguard to see if any program pointers erroneously point to a floppy drive “A” ???  If it does, the DataLifeguard CD (already 5-10 years old) needs to be seriously updated.

Think about it.   The DLGLICE.TXT file can’t be located - even though we ALL know the file does exist on the CD.  Could the program be looking for it on a floppy disk???  Wasn’t the first incarnation of DataLifeguard on a bootable floppy???

  1. Request - Outside of the DataLifeGuard CD and Ultimate Boot CD, can anyone think of ANY other software that might solve this issue?  Let me know.  I’m willing to try “almost” anything at this point.

  2. Final comment.  If I cannot solve this problem myself, I’ll eventually take my laptop into a local geek shop to see if they can get the 500gig drive “locatable” by the Windows installation CD.  Since the shop I’m talking about sold me the two drives, maybe they have some magic answer (grin).   BTW, if you were thinking the WinXP CD might be a problem, nope.  I also tried locating the hard drives with an old Win2K OEM disk.  Also, no go.

But the real final thing I wanted to say is this.  Boy, I’m I becoming a Linux lover, hehe.  Ubuntu installed without a hitch and is firing on ALL thrusters.  And I suspect that the longer I use Ubuntu, the less likely I am to go back to Windows - except for the things ONLY Windows can do - so far, hehe.


#9

All this time, I was under the impression that running DataLifeGuard was “necessary” to prepare the hard disk for installation.  As it turns out, it’s not necessary at all.  It’s just a “nice thing” to have around to check the health of a hard disk when its health comes into question.

In any case, my dual-boot laptop is now firing on all thrusters without any assistance from DataLifeGuard (or WD for that matter).  The reason WinXP didn’t recognize the existence of my hard drives was due to a BIOS setting.  Disabling “native” SATA support in BIOS allowed WinXP to see both drives.  Ubuntu didn’t care which setting I used.  Windows did.

One final note on that.  I’m not 100% sure of this but, as I understand it, only WinXP Pro SP3 has it’s “own” SATA support drivers.  Prior service packs apparently don’t.  And with native SATA support disabled, it will see ALL hard drives bigger than 137gigs as 137gig drives.


#10

@alecwest: DataLifeDiagnostic is “only” a diagnostic tool so yes you don’t need it to use a new hard drive and install an os.

My idea about this very common problem is that we are facing a driver issue: the boot cd, which derives from the floppy version, is not compatible with some controller / hw combination. This is a problem that only wd laboratories can solve.

Marco


#11

Thanks.  I was afraid of that.  Fortunately, I have a dual boot.  If I really need to, I can download the Windows version on my XP drive.  But actually, my Ubuntu drive has a number of utilities that already check the health of hard disks, reformat them, and even write zeroes.