Dashboard v3.2.2.9 blank screen


Tried many different compatibility settings. Win 10 Pro.

1 Like

This is still an issue for me running, running the latest version of windows 10 and yes I do have Razor Chroma products.

The dashboard.log file is really unhelpful.

Thu Jul 7 08:22:59 2022 0x1bc3768 Info: – Cmd Line Args: (“C:\Program Files (x86)\Western Digital\SSD Dashboard\Dashboard.exe”, “-debug”)
Thu Jul 7 08:22:59 2022 0x1bc3768 Info: – SSL Build Library Version: “OpenSSL 1.1.1n 15 Mar 2022” (Build 269488367 )
Thu Jul 7 08:22:59 2022 0x1bc3768 Info: – SSL Library Version: “OpenSSL 1.1.1d 10 Sep 2019” (Build 269488207 )
Thu Jul 7 08:22:59 2022 0x1bc3768 Debug: – framesize QSize(1360, 750)
Thu Jul 7 08:22:59 2022 0x1bc3768 Debug: – resizing to 1 1360 750
Thu Jul 7 08:23:00 2022 0x1bc3768 Debug: – framesize QSize(1362, 782)
Thu Jul 7 08:23:00 2022 0x1bc3768 Debug: – resizing to 1 1360 750

I wish they would resolve this issue. I need to run health checks on my drives. I’m pretty sure what my next ssd purchase won’t be.

Pretty much every single release of this software - Blank screen. Everytime a new version drops, maybe this is the one that will actually work… Nope.

I mean I have a decent high end gaming machine running Windows 10. What could possibly be related to my build. Obviously I’m not the only person that gets the blank screen.

Why is this so difficult to solve. Doesn’t happen with Samsung Magician.

I agree. I’m a software developer and if someone from WD wants to do a remote debugging session or a zoom call to find out exactly what’s going on, I’m game. Come on WD, you can fix this! I suspect there is some conflict with their new qt web engine and something installed on the machine already.

I can’t believe this has been going on for years. I would be fired if I couldn’t fix a bug after this long. Just bought a new SN850 drive. Blank screen running windows 11. Booted into safe mode and updated the firmware.

Have corsair and samsung drives and their utilities load without issue. Makes me regret getting WD now.

Version is still broken for me on Windows 10 21H2 (19044) - still just blank screen.

I have Dashboard installed on a laptop and a self-built PC. It works on the laptop, but not the PC. After multiple attempts and skimming the replies, I decided to check the registry. The folder “Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Western Digital” is different:

  • GUID ← Missing in PC
  • Permanent ← Missing in PC
  • SSD Dashboard
  • Telemetry

I did not make any changes to either registry since I was not sure what the values need to be to resolve the issue on the PC.

Please open a ticket with tech support. They will work with you to try to resolve this issue.

Please open a ticket with tech support. They will work with you to try to resolve this issue.

The registry components that are missing are unrelated to the blank screen issue. It has to do with the graphics drivers and versions and configuration of the Dashboard application.

After a lengthy engagement with support we have discovered that adding BOTH “-disable-gpu” and “-no-sandbox” flags to the shortcut will fix the blank screen on my systems.

Not sure if this will work for others, but you can try it by modifying your dashboard shortcut.

I’m still hoping to find why these flags needed to be added in the first place.


I can confirm that adding "“-disable-gpu -no-sandbox” fixes the issue for me as well.

I’ve opened a support ticket as well, but never made it through to an actually relevant discussion. It’s nice that you were able to actually find a common language with them and find this workaround.

Wow, this actually worked, will open a ticket too.

Thanks! :smiley:

Adding -disable-gpu -no-sandbox worked here too. Not sure why this “fix/workaround” has not been posted by WD ?

Hello. Running version and still had the same problem until I tried the workaround posted here. Thanks!

This fixed the problem for me also (Windows 11 Pro, WD SN550). However I do also have to run the shortcut as Administrator, otherwise I still get the blank screen. I will think twice about buying WD drives in future - it speaks volumes that WD have not fixed this issue for several years.

May 16th, 2023
Still a problem. Yes, the “-disable-gpu -no-sandbox” workaround works, but the app still isn’t fixed.

This had worked for me until my Dashboard software updated to version the other day from v3. Tripple checked the tags remained in the new shortcut, reinstalled etc, will not work.

Somehow WD managed to break the work around, well done.

SN850X 2TB, Windows 11, Nvidia 4070, latest drivers, latest OS patches etc.

You only have to see the variance in different specifications, hardware and OS versions and how many views this thread has (13,500 and counting) to see this is WD, not us!

This definitely puts me off buying another WD product, wish I’d spent a bit more on a Samsung.

1 Like

I had the same problem until re-installed Win 11

You have 2 way:
1.Using v3.8.2.10 (its no big different)
2. Reinstall clear windows

Reinstalling an operating system doesn’t seem like a very sensible solution for this tiny bit of software not working.

Regardless, it worked fine on my win11 for a while after I formatted it. Until it suddenly stopped working, that’s when I used the toggles suggested above… until they stopped working as well, so I doubt it’ll help for long.