Dashboard v3.2.2.9 blank screen

WD Dashboard v3.2.2.9 does not manage to load anything when opened, it shows only a blank, white screen.

I’ve tried uninstalling it with Geek Uninstaller (https://geekuninstaller.com/download), reboot then install again (https://support.wdc.com/downloads.aspx?p=279), did not help.

My system is a Lenovo T490 with Windows 10 Enterprise 20H2 19042.685.
The SSD in question is an OEM “WDC PC SN730”. I’ve only used Dashboard earlier to view stats.

image

I’ve looked for logs in %LOCALAPPDATA%, but found nothing telling of why Dashboard only keeps showing a white screen.

I’ve got the same issue, windows 10 home Version 10.0.19042 Build 19042

I have exactly the same issue, installed dashboard 3.2.2.9 but shows a blank screen.
Windows 10
|Processor|Intel® Core™ i7-3770 CPU @ 3.40GHz 3.90 GHz|
|Installed RAM|8.00 GB|
|System type|64-bit operating system, x64-based processor|

|Edition|Windows 10 Home|
|Version|20H2|
|Installed on|‎01-‎Jun-‎20|
|OS build|19042.685|
|Experience|Windows Feature Experience Pack 120.2212.551.0|

Same issue here with windows 10 64 bits

Works on a different laptop I have with a WD Blue 2.5" 1TB SATA SSD. Toshiba p50a with Windows 10 x64 Pro for Workstation 20H2 19042.685. The WD SSD is in the 2nd bay where a CD ROM usually are located, running at SATA III. Primary SSD is a Samsung 850 Evo 500gb.

I guess it has to do with the WD SSDs in question, rather than the system it runs on. Retail vs. OEM? Or maybe SATA vs NVME?

I have the same issue with a Lenovo T430 and Microsoft Windows 10 Pro (64-bit) 20H2 build 2009 (10.0.19042.746). I understand this can be due to old Video Drivers but mine are up to date. Intel Intel® HD Graphics 4000 version 10.18.10.5161 published 8/6/2020.

Bumping the thread to see if anyone has found a solution to this issue yet?

Same here. W10 Pro. Tried to launch it one day and it was totally blank. Uninstalled/reinstalled countless times. Tried the -disable-gpu route, but that didn’t work. I did find that I can open it in safe mode. However, it doesn’t detect any of my drives. I can’t figure out what’s blocking it in normal mode.

Still a problem for me as well. New Intel graphics drivers since original post, but that hasn’t changed anything.

Just adding URL to my SSD here. It seems “official” enough for me to think it should be supported by WD own software, at a minimum to view S.M.A.R.T stats and similar.

I found that the WD Dashboard GUI loads in safe mode also but will not detect my SSD. And the -disable-gpu command line switch did not resolve my issue either.

Same for me. I paid good money for these drives. Would really like to get this fixed. I’ve updated everything in my system, exited any unneeded programs and it’s still blank.

WD Dashboard version 2.x works fine. It is only version 3.x that has the problem.

Has anyone had any response from WD regarding a fix for this issue?

I got a PM from a user with label “WD Staff” 19. december telling me to contact WD support. I did not reply or contact support. WD Staff, or a member of WD Staff at least, clearly know about the problem now. I should not be required to do anything more IMO.

Makes sense. Thank you!

We are aware of this issue but have been unable to reproduce it in our QA lab or had a successful test release with the customer. If you are affected you can contact technical support to share your system details to help us debug the issue and possibly try some alpha releases of future software, otherwise try future updates to see if we have the fix in place for you by then.

I’ve opened a ticket now, reference 210224-003057.

Seeing same issue. Is there a link to the ticket you reference so we can all follow?

I don’t think these tickets are publically available.

So far I’ve been forwarded to SanDisk support, and have only received standard answer “try to reinstall it”.

I’m out at this point. I’ve offered to give them whatever they need of logs, troubleshooting, this is what I get.

It will probably be fixed some time in the future, so I’ll just wait for that day. :slight_smile:

Thanks for the quick reply and heads up on this. It’s unfortunate it doesn’t work. Will wait for updated version that hopefully fixes the issue