Dashboard partially loading

Just installed my ex2 yesterday, updated to newest firmware and it works (worked) great. Today I changed the device name and rebooted and now it works strangely. Navigating to the dashboard locally and logging in with my admin username and password it works. Then if I exit the broswer, and repopen it, and navigate to the dashboard it automatically logs in, but is not working right. The controls on the dash show no info. Selecting “log out” does nothing. The cloud access tab is missing. The only thing that fixes it is to clear browser cache, and reload it. And then after that if I close the broswer and renavigate to it the problem is there again until I clear the browser cache again, and so on. It is the same in edge and chrome. I don’t recall this happening yesterday, it only seemed to start happening after I changed my device name. I changed the device name back to the default, and rebooted, and the problem persists. Any idea what is going on and how to fix it? I have not tried a factory reset yet as I just got it all setup how I want.

Hi @jtby22,

Please contact the WD Technical Support team for best assistance and troubleshooting: