Dashboard cannot connect to the MyBookLive

I’ve had a 2TB MyBookLive for about 3 weeks. At first it worked fine, but then I started getting errors when I tried to connect to the drive: “Network Path was not found”. The drive would work intermittently, and would sometimes lose its connection during a file transfer. Now I can’t access it at all.

When I try to map a network drive manually from the Windows Network window, the MBL shows up in the list, but when I select it to map, “the network drive was not found.”

When I enter \MyBookLive\Public in my FireFox address line, I get “Network path was not found”.

When I try to connect using the setup on the WD CD - I see the drive name and the details show the right address,, but when I try to map it to a drive letter “A connection to the server was not found”

When I use Quick View - It shows the drive name (0% used, Temperature unkown) with the correct address given in properties, but when I select Dashboard Firefox give the error “Firefox can’t establish a connection to the server at”

I ran Advanced IP Scanner and the MBL is shown with the correct address.

There is one thing that works on the MBL:

I ran Twonky from the Network list, and was able to play a music file from the MBL. The music file properties listed a file location on address

The MBL shows up in the router DHCP table. This is a wired connection. I did get a new Linksysy E3200 router recently. The drive connection on the MBL LED is on and the activity LED blinks, as do the ones on my router. I tried to go back to the old router with only the MBL drive and a computer attached, but got the same results.

And so, I’m going crazy. Does anyone have any ideas?

Thanks for your help

Disable the firewall and/or internet security

make sure on the same workgroup as computer

check with other PC