Crossover cable OK? (My Book World Edition I)


#1

I connected my My Book World Edition I to my computer via a crossover cable.  It runs VERY slow.

When I bought my My Book World Edition I and Gigabit network PCI card at Staples, I told the guy that I don’t have a 1000 Mbit switch.

He said that a Cat 5 crossover cable would work.

I connected everything together and was able to copy files to the My Book just fine.

However, when I copy a large file, I see that the transfer rate is very slow.

Previously I had been using an external hard drive connected via a USB port.  My older Dell computer only has USB 1.0 so it was quite slow.  So I thought that buying the 1000 Mbit My Book would be a lot faster.  Instead it is a lot slower.  A 15 GB file copy took about 10 hours.  When I copy 15 GB between two computers at work (all gigabit) it takes nowhere near that long.

I have mapped a drive and am copying the file via the windows explorer, not ftp.

I would buy a gigabit switch if I was sure that it would help, but I thought I should post here first in case this is a common problem with a simple solution.


#2

First make sure your PC’s network interface is connecting to the WD at 1GB/s, full duplex as follows:

  • Hover mouse over the icon for your NIC - it should say ‘connected, 1000 mbs’ or similar.  Equivalently, right-mouse the icon and select Status. Result should be similar

  • Go into Properties of NIC, then into Configure.  Out of all the options, look for ones like Speed and Duplex.  The default is Auto-negotiate.  Change them to 1 GB/Sec and to Full Duplex

Try now.  If there’s no improvement, maybe your cable is faulty.  Try a different one. By the way, the WD and/or your NIC might have ‘smart’ ports, which means you don’t have to use a cross-over cable.

If there’s still no improvement, maybe your PC is too ancient (you mentioned it has USB 1.0) and cannot satisfactorily utilize a high-speed NIC. 


#3

Thanks for the reply.  I appreciate you taking the time.

The problem turned out to be something sort of weird.  While I was copying the large files to the WD drive, I was also copying some files from my USB drive.  I didn’t think that copying from the very-slow USB 1.0 drive would put much of a CPU load on the computer.  I thought that copying from a USB port and copying to an ethernet port would be completely independent, but apparently not.

Thanks again!!


#4

BTW, just for the benefit of anyone who searches for this in the future… I tried a normal (non-crossover) cat5 cable and it does work.