Couldn't recognize the drive on Windows 7, but possible on Win XP?


#1

I have a 2 TB My Book Studio, serial number is: [Edited], that was working fine for about 1 year, and then suddenly I couldn’t access the drive anymore, so I attempted to format it. After that, it worked fine for several days, and the same problem arised. I take it to my cousin PC (Pentium 4, using Windows XP), and it can read the drive fine. I can access everything inside my drive, but when I tried it on my PC or my friend’s one, both using Windows 7, both can’t access the drive, asking to format it again.

I honestly don’t understand where is the source of the problem, so anyone else has a clue?


#2

I don’t know but have a feeling about differences in NTFS format on XP and Vista and later. Try formatting it on XP and see if it makes any difference. People moving a drive between different OSs seem to have more of this problem. Do you always remove the drive safely? if not you could be corrupting data. TestDisk http://www.cgsecurity.org/wiki/TestDisk might fix the problem or Easuse Partition Manager http://www.partition-tool.com/

Joe