Could not view WD hard disk contents


I have WD 500GB Hard disk.

Currently i am not able to open it.

I got following error on running test: 

Model Number: WD My Passport 071A
Unit Serial Number: [Deleted]
Firmware Number: 2011
Capacity: 500.08 GB
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 17:25:46, August 31, 2012

Please let me know How I can backup data which is there on WD hard disk.


Uff mate,

That’s not good at all.

You can try using Recuva or Photorec, those are free data recovery software. Otherwise you will need to contact professional data recovery service.

I bought a new WD My Passport 1TB and it did not function on 3 different computers. 2 of them with extra power supply to the USB 2.0 ports. 1 without. It just connected a few minutes and then disappeared. Or it could copy a small directory back and forth when testing but then gave up. I tried around 20 times on these different computers but the drive always disappeared after a few minutes at best.

I went to Low Yat SRI Computers Service in Kuala Lumpur since I boght the drive there and it was under warranty. The service is located where they sell network solutions, ADSL modems etc. and the drive functioned like a charm. No problems everything perfect. Both on USB 3.0 AND USB 2.0. Took back the drive, went home, tested on my same computers with different USB ports but nothing worked direct and through multiports. My other external drives all work without problems. The old external drives all work if I use extra power on USB 2.0 multiports but the new My Passport just disappears after a while.

The problem I think is in the way it is factory formatted. It could be used without any problems whatsoever on SRI Computer’s service machine. It has Windows 7 or higher. At home I just use Windows XP and Windows Vista Business.

I was desperate and had no important data on the drive so I downloaded all drivers to the drive 3 different on a Windows Vista machine. Everything installed on my Vista machine. Tested again, does not function more than a few minutes. I FORMATTED IT! (not quick) on Windows Vista. Since it took forever with 10% ready after 2 hours I stopped the formatting. The drive gave the message that I was not having enough user privilege to even read the drive after the failed formatting. I had logged in as administrator. There is nothing higher. Had to restart the machine and the machine could be formatted with Quick formatting.

Lo and behold. The quick formatting took 5 - 10 seconds and the drive was as new and perfect on all machines and it has now copied over 500 GB to it without any problems whatsoever.

Advice which might help:

**1/ You have to use a machine with high power to the USB ports preferably  a multi port that has extra separate power supply to it or a machine with minimum number of other USB connected gadgets. (You cannot use multiport solutions even with extra power on USB 3.0 only on USB 2.0)

2/ If you have data on the WD My Passprot try and try and try until it succeeds on different machines with other operative system, not Win XP, not Vista preferably Windows 7 or better.  Possibly as new machines as possible and with as few USB gadgets attached as possible.

3/ If you don’t have data on the WD My Passport or if you have succeeded to make a backup FORMAT the MY Passport drive, which will take perhaps 20 hours. I interrupted my formatting after 2 hours and restarted the machine and quick formatted it in a few seconds.**


Mine works perfectly now. Copied around 500 GB on to it without problems and usable on at least 2 machines it did not work on before.