Corrupted and Unreadable files. PLEASE HELP

I have a folder on my WD My Passport 1tb drive that, after working in it for several hours last night and trying to opening it again several hours later, said it was “Corrupted and Unreadable”. Now looking at the folder, I am able to open it but all its content is GONE. 

Anyone have any suggestions, tips or anything?


Try using a data recovery software like Recuva.

I ran into the same issue and stumbled upon this thread while looking for an answer. I just tried recuva and it appears to be able to read files from my drive.

I have a recovery underway and should be done in a couple hours at which point I can test some of it and confirm that it all works.

While thats underway, is there any way i can fix up the incosistent file system /mft etc. so that i can continue using the drive. Recuva doesnt seem to offer that option or at least i can’t find it.

one last question - what is the file system on the data partition of the drive. It appears that the Western digital parition (containing WDUnlock.exe ) shows up as a UDF file system

oh and thanks a bunch for the pointer to recuva


If this was a drive for Windows it would have been formatted NTFS. It’s hard to know what causes the corruption. A common problem is people just unpluging the drive instead of using the remove safely routine. Make sure you’re not using a cable longer than the original or connected with a hub. These drives are very sensitive and to many PCs use barely adequet power supplies. Either the longer cable or hub can drop voltage enough to cause problems. something like TestDisk might repair a corrupt disk.


thanks but that didnt work. i tried testdisk and it does a lot of “work” analysing /scanning etc but no avail. 

i also pinged the WD support crew and this is what i heard.