Corrupt Harddrive?

Can anybody please help me?

I have a WD My Book Essential (Model Number WD20EARS) 2TB using firmware 1.015. The above Hard Drive is running on a Windows 7 OS. The computer is a HP Touchsmart, Intel ® Core ™ 2 Duo P7450 (2.13GHz).

I have ripped my entire DVD collection into MP4 format to run through iTunes (airplay etc). There are around 800 films on the harddrive. They are organised in separate files by letter. I have a second, identical Harddrive with my TV series on it.

I have recently moved house. When I came to plug my Hardrive back in after a few weeks in (dry, secure) storage, the drive with my DVD collection appears to have corrupted somehow. (Please note, theey were stored together and the one with the TV Series on it works fine so I have ruled out enviromental damage and issues with my computer.)

The Hardrive is still accessible, and even readable to some degree. However, a large percentage of the films no longer play. They can be seen in Explorer, but they are not showing any length in the information bars - usually a sign of a corrupted or incomplete file from my experience. When you click on the ones that have no length - whether to play, rename, delete, or view properties - the system crashes requiring a reboot. When you click on the folder that these files are in, the green status bar at the top starts running but appears to continue searching infinitely.

I have tried dismounting, uninstalling, and looking for new drivers without any joy. I have also run the smartware diagnostic tool but it sticks at 10%.

The really odd thing is that the files that are working work absolutely fine. I don’t know if it is relevant, but I have also noticed that the harddrive regularly disappears and then comes back again as if it has been freshly plugged in without me touching anything.

Please could you advise me what the problem is likely to be, and if I can recover the apparently lost files. I do not want to have to rip these DVD’s all over again if at all possible and any solution would be greatly appreciated.

Thanks.

I am having the same issue. My hard drive worked fine until about a week ago.  I have it connected to my Western Digital Media Player.  Now only some of the files and folders are showing instead of all of them.  What’s really weird is that when I hook it up to my computer I can see the files but they all have a weird file extension of thumb_73x104 and all of the files are super small.  In addition,  I knew I was close to the final capacity of my hard drives memory and when I look at it on the C drive it says 106 GB free of 1.36TB but all of the files that have the thumb_73x104 extension are super small, like under 30kb’s.  The drive is only a little over a year old so as you can imagine my kids are very upset that all of their movies are no longer playing.  I ran the Data Lifeguard Diagnostics for Windows program to test the drive (this software is provided for free from WD) but it said the drive passed. I also ran the extended test and still no errors.  When I first connected the drive to my computer it asked me if I wanted to 1) scan & fix errors or 2) ignore, I opted for 1 then asked it to automatically fix files with system errors and to scan for and attempt recovery of bad sectors.  After running this nothing changed, the files still have the thumb_73x104 extension on them and do not work.  If I remove the thumb_73x104 and just leave the file_name.mkv the file still doesn’t work.  If anyone has any ideas on how to fix this I would greatly appreciate it. BTW the model info for my hard drive is WD Ext HDD 1021 (USB).

Try posting in the TV section you’ll probably find more help.

Joe

1 Like

Tried it - got a slap on the wrist for cross-posting :slight_smile: