Copying with the WD My Cloud software doesn't copy everything

Hey, just bought the WD My Cloud and am transfering files from an external harddrive to the NAS through the software.

I copied around 200gb from the external harddrive to the NAS. But when I checked the filesize of the copied folder in the NAS it only showed 50gb. I also found a lot of the folders were empty. What gives? Is there some indexing procedure going on after copying, because I copied a folder first but not all files were visible until after a few minutes. I have left the NAS overnight to see if the files would appear the day after. But they are still not visible.

Is there a bug in the software?

I have tried to copy a few big files, but not all of them were copied.

The external harddrive is attached to the USB port in the NAS.

try copying from PC and see what that gives you. I copied from PC about the same 300GB of photos and documents and had no issue what so ever.  At least you’ll know it is something to do with copying from USB.

To load up my MyClouds when I first got them I used a program called FreeFileSync (google it).  Worked fine to transfer many GB’s of data.

I think best to check with their forum as well.

they might be able to advice.

But I used the software to copy directly from the USB drive to the NAS. I don’t want to use the computer to copy files, it will take too long time

But you do not know if it is the 3rd party software or the drive. By doing a test (a tech support will ask you questions to narrow it down) you eliminate the obvious.

Also, by checking their forum you can get more answers and quicker.  Unless someone here is  familiar with software who can answer yoru question.

If I had a second USB drive i would test it as well.

NOTE: fi the 2 drives are  visible to your Windows (assuming you are using Windows), in a DOS command window do as test, choose a directory that has lots of  files, and run


this will mirror the source directory on the destination drive and gives nice stats as well.