Copy pics/vids from USB to NAS

Trying to copy folders with pics and movies from a USB drive that is connected to the EX4.  The WD My Cloud desktop app for Windows does not show the USB drive so not sure how to select the folder to copy/paste.

Also went into the Dashboard to see about creating a backup job from USB to EX4.  It can see the drive and subfolders but I can’t select a folder.

Is this noob doing something wrong?

ps.  I’ve turned off media streaming in settings and shares based on others’ suggestions.

Why would you want to do any copying from within the My Cloud app?? I have never even installed that app.

There’s two ways of doing it…the easiest but also much slower would be to go to Windows My Network -> EX4 -> Name of your USB drive shown as a folder -> Open it and select the files/folders you want to copy -> Also open the folder with share name on EX4 where you want to copy these files to -> Drag and drop them there.

But be aware this could be a long and slow process if it’s a lot of data, esp. if you are using a wireless connection on your Windows laptop/desktop. The reason and the alternate faster way is briefly described in this thread -> http://community.wd.com/t5/WD-My-Cloud-EX2/Very-slow-transfer-speeds-even-when-external-drive-is-connected/m-p/770565

Thanks.  Makes sense.  I guess I need to dust off my unix skills.

Would you turn off media streaming in general and in the shares?  Lotsof pics and vids to copy.

Turning of media streaming in the general and in shares might be a good idea…but I am not sure if that prevents the program wdmc (WD Media Crawler) from running and indexing the stuff. Up until about a month or two ago, I had left my media streaming off but I used to notice that the .wdmc folder would still get created in any folder I had pics and videos…and also I have seen plenty of others complain that it was still running despite having turned it off…I just never bothered checking. Yes, the wdmc of course takes some toll on the CPU but I don’t think there’s any way around it…but if you copy in smaller batches, I think the system just doesn’t get as overwhelmed as if you do a mega dump of say 300-400 gigs or bigger of media files. And yes, that’s a pain to manually copy some folders and then come back after a few hours to check if the last batch got done and if so, then initiate copy of another batch, but in the end I think with a lot of media files it gets done a bit quicker that way. Or you can just copy them in one shot…it’ll just take longer as long as you don’t care…but really, you’ll get best result on file transfer from an USB connected drive if you do it via ssh.

If this helps you, please feel free to give me a kudo.

Is your usb stick password protected? The Desktop app doesn’t support that.

I also tried with a verbatim usb flash drive, and it didn’t work. When I used a sandisk usb flash drive or a wd portable harddrive, it worked.

The Desktop app does support USB drives connected to the NAS.