Copy link and share doesn't work?

Sometimes I want to share a pic or something with a friend that does not have an account on my NAS. I used to go to the file and use the copy link alternative and send it to my friend, but now it doesnt work. the fil is placed in the public folder. I also tried a reboot, but no luck. Help?

Log into the Cloud via www.mycloud.com and share the picture using the sharing feature of mycloud, your friend will receive an invitation email with the link inside.

Thanks. That does indeed help, but I still liked the function better where I could just copy the link and paste it in a chat window or whatever. I saves me the time used to obtain email-addresses and writing them.
The option to just copy the link is still on mycloud, but the link does not open properly. So I need to know what is going on.

What copied link are you refering to? Can you give us an example?

If this link may be accessible by others, please make the link unusable by removing the leading parts :sunglasses:

open the mycloud application on your computer. locate the folder/file you want. Right click it, and select copy link. Then just paste it in an email, or chat window, or wherever.
This used to work before. The recipient just needs to click the link, and it will start a automated download through your browser.
Lately it has not worked. And I trid loging into mycloud.com but the page never opens.
My nas server is up to date and all accounts can be reache through the apps remotely. So I realy don’t know what is going on.

OK,correct way - nothing to claim here.

try to use https://files.mycloud.com/login.php for direct accessing the login page, maybe there are some DNS issues on your line. My Cloud Portal pages are not “under construction” or temporary unavailable.

the link just lets me sign in, and then the page says signing in, but does not move on from that point. nothing happens??

Strange, from my internet line here I can signup and walk through the cloud devices.

Maybe you should clear your browser cache…
BTW, browser, which one do you use?

I use opera

Can you use something different like Firefox or Chrome?

I’ll try

I get this error in chrome

Error

The server encountered an unexpected error which prevented it from completing your request. Please close this window and start the sign in process again.

Clear the “Temporary Internet Files” on your PC by using the “disk cleanup” within Windows.
For me, it seems that there are some broken / cached files still in your system.

done, but still not working. When I open the application, there is a message about the certificate. Can that have something to do with it? Also I tried to update the user registration, but got “Failed to update device user. (400068)”

it says the certificate I am viewing does not mach the site I am trying to view

I reinstalled the desktop app and it seems to have fixed the copy link functionality, but still cant log in at mycloud.com

It should state that the certifacte cannot be verified - as it is a generic certificate if you are using “My Cloud Dekstop App for Windows”. This is not related to mycloud.com.

Have you changed the email address which is stored on “Cloud Access” pages inside te web interface of the My Cloud device? Can be related to an authentication issue if cloud access points to an email address which is not (yet) registered for having access to your My Cloud device.
This can be checked with “Cloud Access” tab of the web interface.

it says it’s connected. And I have not touched the address in ages

Sorry but we reached the stage of my last possible answer: get in touch with WD Support teams.
Honestly, I am lost.

it’s, ok. I appreciate your effort. And thanx alot for trying. :slight_smile: