Converting/Formatting 2.5TB WD Elements to FAT

Hello, all.

I purchased a 2.5TB Elements external drive (let me know if model # or anything would help and I’ll nab them off the box and post). I primarily use a Mac (OS 10.4.11), which is why I would like it to be set up as FAT. My work laptop is a Dell, so I do have access to a computer with Windows XP if that would be any easier to do the conversion/formatting on.

Anyway, whenever I try to follow the WD instructions on how to do this on my MacBook (using Knowledge ID# 287), Disk Utility locks up as soon as I select the drive and click “partition.” I’ve tried this multiple times on multiple occasions and the result has been the same. So, that’s when I decided I’d hook it up to my Dell and just do it on there. That was about a month or two ago, so I don’t remember the specifics, but it wasn’t working, either. Then, I tried on my parents’ PC with Windows 7 and we couldn’t get it, either.

If anyone has advice or insight on how to convert this (even if it’s only a 2TB partition of it because it can’t be more), I would greatly appreciate it. I’ve tried scouring the net quite a bit before resorting to this post and I’ve found some overlap in what others have gone through, but I haven’t found a very clear solution.


Fat 32 has a max file size of 4G will that be a problem? Something else to consider. Leave the drive formatt as is NTFS for Windows. Then on the Mac install NTFS-3G and you should be able to use drive on both Windows and Mac. FAT32 is also more prone to corruption. 


1 Like

Thanks for the post, Joe.

The 4GB file size wouldn’t be an issue for me.

I went ahead and downloaded the NTFS-3G program you linked (thank you, by the way). When I plug the drive in, it’s still not showing up unless I go to Disk Utility. Any suggestions? Based on the user manual for the program, it just works and you don’t have to do anything with it, but I tried looking in Applications and didn’t see it even though it’s been installed and I’ve restarted the computer.

I don’t know much about Macs but on Windows you just plug in drive and it installs a driver. I don’t know what Mac calls it but in Windows sometimes you need to go into Disk Management and give the drive a letter.


I just thouht of a couple more things. For drives larger that 2T they need to be formatted GPT instead of MRB in Windows. Does your Mac  recognize drives larger than 2T? That was a problem earlier this year. So you might want to checkout your Mac and make sure you have all of their updates.


I ended up formatting the drive on the laptop using XP. I was thrown off initially because the knowledge base ID said for XP that it wouldn’t recognize drives larger than 2TB, but that must have been a 32-bit/64-bit thing. I formatted it into a 2TB partition and a 380GB partition; both NTFS. After that was complete, the Mac brings them both up perfectly, now, thanks to the NTFS-3G program you suggested.

Thank you for the help, Joe, and particularly for that program, as that was the only reason I wanted to use FAT32 on my externals.

When the LBA size is 512 bytes, the maximum MBR partition size is 2TiB.

However, in your case the external USB mass storage device is configured for 4KB LBAs. This means that Windows XP can address up to 16TiB.

I suspect that FAT32 doesn’t understand 4KB LBAs, so that may be why formatting failed.