Control Doesn't Work

My dad recently bought a WD TV Live we put everything in place, the jacks the usb connection but the controller doesn’

t work at all. We tried different fully charged batteries and it still doesn’t work. Any solutions?

I assume you mean the remote control. Does the WDTV work. If you connect the leads etc and then plug in it should switch on (LED on front will light up).

Yeah the wdtv works, were on the screen but when we press the control arrows it doesn’t move to the right or left

You said you’re using rechargables.   You might try using regular alkyline batteries…  like the batteries that came with it.

when we used those it didnt work to

Point the remote at a digital camera and see if the front LED’s light up when you press a button. If the remote is working you should see them glow red on the camera screen. Use only normal batteries as re-chargeables have a lower voltage.


If after trying what richUK said you still have the same problem, contact WD to get another remote control