Continuous Play Broken

Is it possible that the continuous play has been broken in the latest build?  

I can only play one video when I start WD TV.  I use to be able to play videos continuously before the last upgrade.   I have to restart my WD TV to play the next video.  I tried everything from resetting the WD TV to reinstalling a new serviio server.  

Tomorrow, I will try downgrading the WD TV ,

What is the latest build

What is the model number of your player?


The latest firmware version is 2.01.86

My model number is the WD TV Live Streaming Media Player.  I purchased it at Costco about 6 weeks ago.

Part number is WDS-G70000NBK-02.

Thanks very much for your response.

PS:  This is the best media player I have ever purchased.  I have many TV shows on Serviio and I usually like to play all the episodes continuously (while I do other work).

I have exactly the same problem after installing the latest firmware: 2.01.86. Both with .avi files and playing a video_ts folder. When starting a second video, it continuously shows the spinning loader…
Also, maybe has to do with the same problem, if I stop a video, it continues to play in the background. I cannot really stop it, unless I force it to stop by shutting down the whole mediaplayer. Very strange, the player always worked well.
I play my files from a networked NAS over UTP.

Edit: sorry, I have a WDTV Live Streaming Media Player…not the correct forum I guess…but the same problem…

Don’t worry its been moved to the correct forum.

I want to let everyone know that this is a reoccuring issue with these machines.  Take a look at this tread:

Obviously there are quality issues.

I will retrurn my unit asap.