Content won't load on

Hi everyone,

For the past two days, I can’t access my files via
I can login, but then I’m stuck on the home page, and it won’t load. I’ve waited like an hour, several times.
The blue wheel keeps turning…

I tried turning my WD off and on again, I tried quitting and relaunching my browser, I tried on Firefox and Chrome…
Everything else is ok : I can access my files via the desktop, add and remove files. But I need to access my files online to share some of them.

I don’t know what’s wrong.

Does anyone has an idea ?

Thank you.

The issue is on Western Digital’s end AGAIN.

Their service went down on March 9th and was not fixed until March 19th. It only lasted until March 24th and has been having issues since.

Take a minute to read some of the existing threads… that state they can’t connect either.

Oh that explain a lot. I was just reading some threads indeed.
Thank you !

No problem,

Not sure if they are aware of the issue this time. I haven’t called.

Just know that Western Digital’s My Cloud status page does not reflect the actual status or all the outages. When it went down on the 9th, they did not update the page until the 18th. That outage was from 3/9 to 3/19; they posted on the 18th to give them 24 hours… making it seam like they fixed it quickly.

That being said… it could easily be over a week before they fix it; or even update the status page.

Great… xD The status page sure is confusing.
Anyway, guess I’ll stick around to check for news…

@Aaricia86, @juicebox Where are you located? I’m in the USA and have it opened in another tab and both of my WD MY CLOUDS work. I am using Windows 10 Home and Microsoft Edge.

In US.

Tried Edge and Firefox. Also, the phone app for android. None work for remote or local viewing.

Currently can only access the files by mapping the drive over the local network to a computer.

I’m in France.
And I’m using MacOS X.