Content scan error, help needed

I have recently disconnected my WDMyCloud Drive whilst we were on holiday. Upon returning I reconnected it only to find that there does not seem to be any media content on the drive anymore. The dashboard shows an error under the content scan section. I tried rebooting, 4 second resetting it, stopping the services and restarting it, rescanning, rebuilding to no avail. I am now at a point of doing a quick factory reset but wanted to see if there is any alternatives and I definitely need to recover media from the drive.
Thank you

What have you looked at, other than the Dashboard, that shows there isn’t any media on your My Cloud?

Are users and shares still showing?

What devices and operating systems do you use?

Hi there. I run Win10 on a Lenovo ideapad Y700, multiple devices connected to wired/wireless network. I am able to browse the content using Putty and have started copying the files to another hard drive using secure copy although it’s a slow process. Just didn’t want to risk losing the drive content by doing a quick factory reset. Is there a better way of doing this perhaps?


Can you see the drive in File Explorer? Can you map drives?

1 Like

I can see WDMYCLOUD device in explorer but no content and unable map
drives. Only when I ssh using putty can I see the shares and content.

I think it’s time for a 40-second reset…

If you can do a proper shutdown first; if you’ve got SSH access, do:

shutdown -h now

Done that, shutdown ok, then unplugged for few minutes and restarted. Same old same old though, still unable to see wdmycloud shares on network, so continuing copying to another hard drive to salvage what I can. Even tried to rescan, rebuild media server content using the console – the rebuild scans up to 10000 tracks and then just gives up. Not sure if there is a manual stepbystep startup process to mount, rebuild, etc. Anyways hoping to do a factory reset after I copied all I need which will take me a few days to do. Sigh ;-(

Try a 40 second reset if you haven’t already as suggested above. A 40 second reset generally does not remove any user data. Instead it just resets the My Cloud settings to default.