Content Recovery after Resetting - Red LED Light

Hi

I am using WD MyCloud 2TB from last year without any problem.

Few days ago, LED light of WD my cloud turns red and showing 0 KB free in capacity. There was a critical diagnostic error with content status “Not Mounted”. I reset is with 40s method. LED light turns blue with no diagnostic error but 0 KB free in capacity. I tried everything but not able to recover the contents. Today the LED light again red with same old critical diagnostic error. I tried SSH but left in between because I am not a computer expert.

Please advise as I have very important data in that cloud. When I try to backup on network, user name and password not working for my Mac. I just want to recovery my contents and now no concern if it will again in working condition or not.

@tmmirza Did you buy your My Cloud new or used? Do you know if it is a 1st generation or a 2nd generation?
1st has firmware 04.xx.xx, 2nd has 02.xx.xx. Look at LEDs in the User Manual for your generation and see if that helps you.