Constant Red Light Help!

Hi guys,

New to forums and not very technically minded when it comes to IT so please be gentle with me :slight_smile:
I have a WD 3.0TB My Cloud that suddenly stopped working and became inaccessible whilst displaying a constant red light.

I have tried a soft restart (hold reset for 4 secs) several times but to no avail and have also tried a hard reset now on a number of occasions but nothing. I also tried a different network cable and different port on router and combinations of both, again to no avail.

I then resorted to removing the drive from the casing and purchased a dock in orders to try other methods I’ve read online. I’ve inserted the drive numerous times into the dock but have only ever managed for the drive to be seen on one occasion but since then (and have tried multiple times since), the drive is just nor seen. I’ve tried a different drive in the dock several times and each and every time it has been seen. I’ve also downloaded software including the Paragon software designed to read linux files/drives as recommended in another topic, however again it did not see the drive?

Therefore the dock seems to be working correctly however is it possible that the WD My Cloud drive has become hidden some how or inaccessible?

We’re desperate to retrieve the data is it contains family pictures that mean the world to us! Ironic that we originally identified the issue when we actually went to back up the pictures!!

Any help/guidance/solutions that you can offer would be greatly appreciated.


@Zoskie You haven’t said if this is a 1st or 2nd generation My Cloud? Sounds like a 1st generation.
Have you looked at the User Manual for your generation of My Cloud? See LEDs.


Having checked the unit you’re quite correct, it’s 1st generation.

As far as I’m aware it’s not a temperature issue and have tried different ethernet cables and ports and established that the cables worked with other equipment as did the ports. Therefore how do I establish if it’s one for the following:

  • Disk SMART failure

  • Data volume does not exist

  • System volume does not exist

I’m struggling to see how I would be able to identify if I’m unable to actually access the drive?


I’m right there with you Zoskie. I am following as this is the same problem I am having.