Constant blinking green light after OS reinstall


I recently upgraded to Windows 8 and was having a few small problems, so I decided to do a fresh install.

Seeing as I didnt want to lose my years of pictures and music, I bought the MyBook Live to connect to my Bell router.  Initially Windows 8 wouldnt find it, so after about 30 minutes I worked out that Windows Defender was blocking, so I disabled it and finally it found it, although it was very touch and go.  I spent about 5 hours transferring my 500GBs of stuff on there and then decided to reinstall Windows 8.

The problem is, now that I have a fresh install of Windows 8, the green light on the drive wont stop blinking.  Windows cant even find the drive at all, even with Defender disabled this time.  I’ve pressed the reset button a few times now for four seconds, and it stops for a second then starts again, i’ve unplugged the Ethernet cable, and took out the power cord for 30 seconds, and its still the same thing.

Obviously, with Windows not even being able to detect it I cant use http://mybooklive/ to access it, and i’m running out of ideas.

Any help??

Working great here in Windows 8. I didn’t have to disable Windows Defender at all. When setting up Windows 8 did you enable sharing and network discovery? One of the first things I also did was disable the homegroup. I don’t know if either of these are what are causing your problems though.

As far as the blinking green led goes, the drive is indexing all of your photos. Could take days depending on how many photos you have on there. You could disable this, but then the WD Photos app won’t work.

To disable it, if you can get to the dashboard, go to shares and click a share and change media serving to NONE

I do remember enabling sharing and network discovery but i’ll double check that, thanks, plus i’ll disable homegroups.

I’ll also change the media serving to NONE, just in case, but I dont think that would make a difference right now as it cant find the drive.

I’ll report back soon :slight_smile:

OK, just got home and checked my settings.  Network discovery is on, and I left the Homegroup.

Still the same issue.

One thing, if I disconnect the ethernet from the router the green blinking stops.  If its indexing its own files and not accessing the network would this still happen?

Its been 3 days now, exactly how long should I wait for this?

Can you ping it?

open cmd prompt and
ping mybooklive

Tried it, it said could not find host mybooklive, please check the name and try again.

I’m guessing it’s a network issue.
Try a different ethernet cable
Try hooking the MyBookLive directly to your computers ethernet port to rule out any router issues
Try a different port on your router

OK, so I finally had time to do your suggestion.  Connected directly to the ethernet port of my PC and its still not recognized.  The green light is STILL flashing and its been 5 days now.

This is getting ridiculous.  My first WD product, with 500GBs worth of data and I cant access it.

There has to be something else I can try.