Connection failed after update?

Okay, mybook duo was working just fine, so I updated it last night.  Now it won’t stay connected, I can watch a movie from my iPhone for about 32 minutes, then it says “device offline”   This was not happening before I updated the software.  So I went to the UI, and the automatic connection box is checked, but it says “connection failed arror 31520”   Any suggestions on this one?  I can still read and right to it from windows explorer, just have issues streaming movies to it for more than 32 minutes because it goes off line.;

Try setting the remote access port manually instead of automatic.  You are going to have to assign new external ports, in the DUO UI, and then make sure that these settings match the port triggering settings of your router.

What settings are recommended here?  I’ve never had to tinker with this particular setting before, and don’t want to mess things up.  Any reason why this has to be done with the duo?  And not with the MBL 3TB?  When I had a MBL 3TB, it never lost connection.

The reason I had to do this is because the DUO’s UPnP service does not seem to play nice with my router(linksys e4200).  In theory, the DUO is supposed to set these settings without any user intervention.  It provides the router with the port it needs to use, and the router routes traffic on those ports to the correct device within your home network.  Although all of my other devices in my network work with my router, the DUO does not.  At this time it is a blame game.  Linksys blames Western Digital, and Western Digital blames Linksys.  Go figure.

   Question:  In your DUO, if you go to the settings>Media, what does it say under Connections Status: “Connected” Port forwarding connections established, or does it say something related to Relay mode being utilized?  If you are getitng the relay message, you are definitely having UPnP issues, which may result in what you described in your original post.

  I was getting the relay message, then I switched to a pseudo static ip (DHCP reserved IP) and set up forwarding according to this guide ( )).

  Good luck.

Strange, that’s the exact router I’m using, only it’s the second generation 1, just released in November.  I will try this and see how it plays out.  Thanks.;

This link takes me to a page that says “permissin denied”  Do I have to set up another user name and password to look at this guide?

I also have version 2.  Hopefuly a firmware upgrade is coming soon.

  The link was copied from inside the web UI of DUO.  if you go to the remote access menu, and select manual setup, there is a link for more info.  click on that.

Found it, where do you manually inter the gateway and netmask?  I found where to change it to dhcp, but it wouldn’t let me change those 2.  Might just send this thing back.

in hthe router setting, you have to used the advanced setting, not the cisco at home application.  You can get to the adanced settings through cisco at home, or just type in the address bar of a browser.  then look for port trigerring, the menus should look pretty close to the screen shots provided by the how to on the DUO.

Okay, found everything I needed, but once I click save, it tells me that my net mask does not match ip range or something like that.  I Checked the range, and the IP address is within range, do I have to change net mask also?  Sorry, new at this kind of thing.

My fault, it’s the gateway that it is saying is not matching with IP range

Okay, kind of confused here.  I enter the netmask, and gatway, and even the dns, but it tells me that my gateway and IP aren’t in the same range.  When I go to port trigering, the edit fields for netmask and gateway are empty.  Whaere should I be getting my mask and gateway numbers from, since 1 set is blank, and the other set on the duo is giving me an arror.  Why can this just be simple?lol  Maybe it is, and I’m just missing a step.

here is an example:

DUo should read:


WD 2go Port 1:     1524        80 is the DHCP assigned & reserved IP of the DUO)

WD 2go Port 1:     3000        443 is the DHCP assign & reserved IP of the DUO)

Linksys should read:

WD 2go Port 1:    1524        80    TCP is the DHCP assign & reserved IP on the router) Check(enabled)

WD 2go Port 1:    3000        443   TCP is the DHCP assign & reserved IP on the router) Check(enabled)

  Make sure the ip is resevred in the DHCP reservation table.

  You do not need to touch anything related to netmark or gateway on the main page of the advanced setting of the linksys.

  On the network page of the duo:  (per example above) should be the ip  netmask



Wooo!  Your talking about the DCHP, and the help page I went to told us to change it to static.  Whitch one should it be?;

Don’t mean to be a bother, but let me explain why this is taking me a while.  I am totally blind, and using a screen reader, and it doesn’t always read things as it should.  I got all the way up to selecting the source within my router page, but then it says something about ports and check boxes that I can’t find.  Guess I will have to wait for a pair of eyes to help me.  Thanks for putting up with my ignorence.

Not a problem.  Good luck with it.

Okay, think I have figured out the layout.  Last question.  Do I go in to range port forwarding, or single port forwarding?  Also, you list both ports as 1, is this correct, or was that a typoe?  Last question, my duo has the IP address that ends in 108, will this make a difference?  Thanks a bunch!

single port

typo, the second line should read 2 will work just as good

not a problem.

Finally got the numbers where they go, rebooted the duo, and all is well!  Now if I could just get my xbox360 to stream the movies we will be good to go!!  Thanks to my fellow poster, can’t remember his name off the top of my head, but he was very patient, this forum is much more helpful then customer service!