Connect to WDTV Live on Windows

Ok so I have a WDTV Live plus. My network used to be set up as follows:

           Modem ----> Router -┬–> Net Gear Universal Wifi Adapter -----> WDTV Live Plus

                                                 └–> Computer (Windows 7)

And when i went into the network section of my computer if showed up and i could access the hard drives attached to my WDTV Live Plus

I now have a few more devices attached to my TV that i needed to add a router so now my network is like this:

           Modem ----> Router 1 ┬–> Net Gear Universal Wifi Adapter -----> Router 2 -┬—> WDTV Live Plus

                                                   └–> Computer (Windows 7)                                            └—> Blue Ray etc.

So now the WDTV Live pluss doesnt show up in the network window on my computer. Is there a way i can access it still.

Router 1’s Gateway is and Router 2’s IP is

Router 2’s Gateway is and the WDTV Live Plus’ IP would be 192.169.0.X (it is DHCP)

If anyone could tell me how I can connect to it I would appreciate it thanks :slight_smile:

Don’t plug Router 2 into Router 1 using the WAN port.  Use the LAN ports instead.

Microsoft Workgroups don’t work across actual “Layer 3” routers.  By plugging in via LAN ports, you’re actually turning Router 2 into a SWITCH.

Thanks for the reply. I tried what u suggested with a slight modification. I need to use the netgear wifi thing to get the signal upstairs to router 2, so the signal goes from router 1 through WiFi then received by the netgear thing then out into an either net cable and then into router 2. I was running it into the wan port of router 2 and when I switched it to a LAN port it didn’t work the devices attached to router 2 couldnt connect to the Internet. Is there some setting I have to change for it to work?


Ok Thanks for your advice after a bit of googling I figured out what was wrong…

So Like you said its cause it is a Layer 3 Router and it needs to be a switch… so to make it act like a switch i needed to go into the settings on router2 and diable DHCP and change the IP to a ip that is in the possible IP range of router1 but not in the DHCP range of router1. Then i needed to set the router2s IP to a static IP at the same location.

So Summary:

Check the DHCP Range of Router1 (in my case it was

Go into Router2 and Disable DHCP

Change the LAN IP in Router2 settings to (or any other IP that isnt being used and isnt in the DHCP Range)

In Router1 set Router2 to have same static IP at

Plug the LAN cable from Router1 into a LAN port on Router2 (not the WAN port)

Note: for me Router1s IP is

This worked for me thanks for your help