Computer not reading MyPassport

I just bought a new computer and it won’t read my external (MyPassport Essential 500GB). I have tried all the info I could find about it on here. 

My main issue is that it worked flawlessly on my older computer, however when I first connected to my new one it prompted me to load drivers, but it never installed the WD Smartware software like it did before. After going through the installation of the drivers I expected to find it in My Cpmputer as usual, but to no avail. The computer recognized that it was connected, but it wouldn’t “read” the drive so to say.

I tried this also on a friends computer and it did the same exact thing.

I am wondering if the reason is because it is somehow synced to my old internal hard drive? Or maybe the password protection on it is causing this? Any and all help would be appreciated.


Did you hide the vcd?  Otherwise, you can download Smartware at the link below and install it.  That’s probably a better idea anyway.

I don’t think I hid the VDC. BTW that link doesnt work.

I was the same prob with my passport essential(320gb)and i found this solution from win7 and from computers with 

NVIDIA USB EHCI chipset and at least 4GB of RAM.For more details read bellow:

I have a 120 g that worked with a PS2 Lenova, and more recently a Windows 7 Dell. It began intermittently disconnecting and reconnecting, then didn’t work at all. I used a different cable, which cured it temporarily, but now the computer doesn’t recognize it at all.  A reboot (or unplug/replug) produces a few two-toned beeps, but the computer does not recognize the drive in “my computer”. The 'remove drive safely" will recognize its presence, and the device manager says the drive is functioning properely. Ironically, I just bought a 1T from WD as a backup. Am I too late?