Computer can't find Hub


After the latest firmware-update my computer can no longer connect to my Hub. They can both access the internet, and my computer can stream media files FROM the Hub, but I can no longer access the folders on the Hub or transfer files from my computer. WD Discovery can see the Hub but when I click on “Browse Network Shares” it fails with the message: “\WDTVLiveHub The network path was not found”.

I’ve tried downgrading the firmware and reset all the internet settings, I’ve also tried to connect with an ethernet-cable but nothing seems to help. How can I check to see if all the basic settings (the IP address etc.) are correct on both my PC and Hub? I suspect that some configurations might have been changed because I can’t figure out what else could be the problem. I hope someone can help me!

Regards, Henrik

Ps. In your answer please take into account that I’m not particularly good when it comes to setting up networks, IP addresses and so on. 

I had the same issue, but it worked after i disconnected the original network drive and then re-ran WD Discovery.

Another suggestion might be plugging in your laptop to the ethernet to set this up.

Hope this helps.

Thanks for your response!

How do I disconnect the original network drive?

I’ve tried connecting my laptop to the Hub with an ethernet-cable. Do you suggest I try to connect it to the router instead?

I’ve now noticed that my network details says:

“IPv4-connection: Internet”

“IPv6-connection: No network access”

Could this be the problem? As I mentioned before, I’m no expert in this.

Disconnecting the network drive is as simple is right-clicking on the assigned drive in Windows Explorer and selecting “Disconnect”.

I suggested connecting the laptop to the network via ethernet cable (not directly to the Hub - assuming your hub is connected to the network too) to ensure it wasn’t a wifi problem.

Hopefully that works, although i did read elsewhere that others were having issues like this where they had not fully downloaded the latest firmware (i.e. it had not completed).  If this is the case, you will need to rollback and then re-download the latest firmeware.

Hope it helps.


Exactly the same thing happened to me. I think that it is due to the 2nd part of the firmware upgrade process failing. I think you need to roll back the formware upgrade. Check out this thread


The first time I upgraded the firmware, It halted during the 2nd part of the firmware. But later when I retried, it was installed without any problems. Since then I’ve downgraded it and then reupgraded it - also without any trouble.

I’m sorry to ask a stupid question, but how can I disconnect the network drive if I can’t see it? I assume you refer to the Hub as a network drive?

I had an incident yesterday where I could see the Hub and my Live Plus as Media devices but NOT as shares. I had been using Thumbgen on one of the computers and accessing the Hub. That computer saw  it all as it should have but my other computer couldn’t see the Hub or the Plus. I tried rebooting the computer that couldn’t see them, no joy. So I rebooted the computer I had been using thumbgen on and viola! everyone was happy again. I dunno if it was some bug or not from Thumbgen. I have no idea what caused it to happen. But maybe this info will help someone else that has lost connection to their devices. Basically, just reboot all your computers and see if it comes back.