Compatibility problems

I own a 1TB Elements hard drive; this is not any wireless, not the network storage drive; nothing to do with cloud; its just a regular hard drive. I have a very frustrating question to ask viewers reading this and the support team:

I can access my files and play stuff directly off of it, if I had it connected to my computer. However its when I plug it into a WI-FI card reader box, that it sees the drive, but can’t access my files, I can’t even browse. I first noticed this with the Kingston Mobile lite G2; and the 3.0 hard drive should be compatible with 2; I have a Roku Sharp Smart TV and the Roku Media Player app is able to access the folders and play stuff back;

I do not have any software on the drive either; Keep in mind that I have another hard drive, a 1TB and that one works on anything; keep in mind that I also have tried using external power, using the Y splitter cable; but something is very strange; I don’t even see any options to access settings; do all WD hard drives come with some type of security firmware and you need some type of software to turn it off; because whatever it is, its unique to WD drives. I plug it on and none of my devices can see the files, its as if they weren’t there.

Whatever is blocking other devices from not seeing its content, and if there is some kind of security thing, how to I turn it off?:roll_eyes:

First thing I’d check is to make sure the drive’s format and partition table type are compatible with your other devices.

If you have a drive that works with everything, plug it into your PC and see how it’s partitioned. MBR or GPT?
Then see how the partitions are formatted. ExFAT or FAT16 or FAT32 or NTFS or…

and then set up your elements drive the same way.

I don’t recall if the WD Elements had security features on it or not. But for sure, if you didn’t explicitly enable it yourself, it’s not on.

I’ve not heard of MBR or GPT.
The hard drive is in its default NTFS file system, and my devices do support NTFS.

I must research what the MBR means and how to check that in Windows 7.

I don’t use the Kingston Mobile lite g2 box thing no more because I found an app, the Paragon NTFS mount, I had to pay a few dollars but this adds support to android devices that support otg , via otg adapter; it converts the micro usb port to usb 2.

I Think my tablet was able to access both hard drives. You use that start commander app to browse , and the other app just mounts it.

The box I use now for tvs that have no usb port or don’t support video playback of any kind , is the Von Hause Nano 3.0; it outputs to rca or hdmi from the box, and supports up to 2 TB.

I must check that MBR thing.

by the way, just so that everyone knows…
Wi-fi card readers work ok, but occasionally the video will pause, I had to min the app and then tap the corner for full screen and would tap play and it would go again; the direct connection is smoother , faster and no delays

Android devices that support otg would require you to root the device , the Paragon NTFS mount app does the work without root.

I did a command prompt and the hard drive that works is not set up for either MBR or GPT; the one that only works for computers was partitioned as GPT. It looks like I will have to move stuff off of it, and re format it with to the most compatible one.

It’s gotta be one or the other. :slight_smile:

If you have Windows, open a command prompt.

Issue the command “diskpart”
When diskpart opens, issue the command “list disk”

It will tell you whether it’s GPT, and if not, it’s MBR.


In my example, my disk is GPT.

There’s good news: it was in the wrong partition; so after 6 hours, of moving files over, I used partition Goru, a free program to convert it to MBR. I loaded a file on it and it worked on the VonHauae Nana 3.0 Digital media player ; finally …

And thanks for the help. Wow who would of thought .