Cloud Data Base keeps getting corrupted

I bought 2 DL4100, one for a server and one for a backup device. They came with 2 4TB drives, I added 2 more to each for a total of 16 TB in a raid 5 configuration. I’m able to read and write and all the backup jobs process. I’m able to access via cloud without issues. I have the latest firmware on both units (2.10.310). I have media serving turned off on both units. The issue I’m having is with the cloud database constantly needing to be rebuilt. What is happening is the main page will show the total space of all files but will not show the break down of Videos, Pictures, and Music. All those show as 0kb. But if I rebuild the cloud database (option under Settings|General|Cloud Service|Configure|Cloud Access–Cloud Configure–rebuild database) those will show the totals for a couple of hours and then reset to 0kb again. This issue also affects the WD Sync function. It will not work unless the database is rebuilt 2-3 times a day.

Does anyone know how to remedy this issue and why it happens?

So no one else has had any issue like this?

Hi there,

Try to do a system only restore on the unit to see if this helps, it is not normal to have the database rebuilt 2 or 3 times a day. Here is a link on how to do a system only restore on your device:

I tried a complete factory restore prior and have the same problem as I did before the factory restore.

I’m convinced it’s some setting combination that’s causing it. Just haven’t figured out what it is.

do you mean like this?


my dl2100 looses not only info but sometimes also cloud devices. i found that if i turn off Cloud access, info page shows just the free space left - it disappeares data info. Turning Cloud access on, the main page works again.

you can find many similar questions among “my cloud” series.

i have manage couple of times to fix that issue by using Disk scanning function from the settings tab. but it doesnt seems to work when Cloud access is off, only when it is set on.

System restore/etc. wont work, it always comes back.

That’s not quite the issue I’m having. I had figured out that turning off cloud access gave the space readout as it is in the red box you have highlighted. What is happening to me is the first picture you have there will show the total capacity along with the breakdown of categories: Movies, Photos, Music, Other and Free. Initially all these capacities will populate but after a few hours, the Movies, Photos and Music categories will show 0 Kb and the “Other” category will show the total size of all files. Going to the Settings tab and general and then cloud and configure links bring up a window that has an option to rebuild cloud content database. Rebuilding that will then again show those categories disc space occupied populated again for several hours and then back to 0 Kb. I can’t get it to stay populated. This also affects the ability of WDSync to work properly.

For what it’s worth some of my other settings: I have no apps installed or running. I would say the only “non standard” settings I have is manual port forwarding using different external ports that are then forwarded to the standard internal ports. All the cloud functionality works just fine. I have multiple backup jobs setup to backup to a second DL4100 and those all work just fine.

I am running 4 4 TB drives in a RAID 5 configuration. This is the only thing I haven’t tried to change and don’t want to. I have tried a full factory reset after the firmware update and had to move all the files and setting all over again.

I haven’t had the cloud issues you have had. I’m going to try a few other things but I find it confusing I’m the ONLY one having this issue and I’m having it on two identical units. I’m starting to wonder if having 4 4Tb drives in a RAID 5 configuration is the issue?

FWIW, the recent firmware update seems to have fixed this issue.