Cloud Access disable after change disks

Hello community,
I have a serious problem after change my disks of the My Cloud EX4100 system. I had installed 2 disks of 2TB each one. I replaced with 2 disk of 4TB because I need more space, I did the RAID 1 array and the run the backup to copy all the data in the new 4TB disks. The problem was the system give me an error during the restoration of the data so I regret with the 2TB disks. Now the system don’t let me access to the Cloud Access and I can’t see the data in my 2TB disks.

This is what I do, step by step:

  1. Turn off the NAS.
  2. Change the 2TB disks for the new 4TB disks.
  3. Build the RAID 1 array.
  4. Run the backup from the external hard disk.
  5. The system give me an error during the restoration of the data.
  6. The Cloud Access service don’t let me enable it.
  7. I turn off the NAS, change the 4TB disks for the old 2TB disks.
  8. The system don’t recognize the disks, the system say I have 0kB space free and still disable the Cloud Access. The strange is the 2TB disk before the change they have 95GB of free space.

NAS Home

I can see the NAS system in my local network. If I go to “Cloud Access > Sign In” I have the following

NAS Cloud Access

If I try to sign in I have this error message

Cloud Access error


I did a “Quick test” (Settings > Utilities > system diagnostic) to the disks and are ok, without problems.

The firmware of the system is 5.27.161

If I connect the external hard drive with the backup in a windows pc I can see the backup data without problems.

Many thanks in advance for your help, regards.

Of course you can`t see data when just put back old disks.

The best way copy backup data from PC to NAS by LAN

What do you mean “error during restoration of the data”?

How were you doing it? What went wrong? Did you try again?
As suggested above; I am a big fan of “drag and drop”; doing it in “chunks” for large drives.

When you put the 2TB disks back in. . .did you check the “raid” status? I think it would have prompted you to choose between wiping the disks as if they were new, and importing the disks as a functioning Raid (“Raid Roaming”)

Hi vborets,
Many thanks for your answer, but if I copy 1.6TB of data will show me a classic error message for the long file names. I prefer a sync work in that case.


Hi NAS_user,
Many thanks for your answer. With “restoration data” I mean when I tried to copy from the external hard drive (the backup) to the new 4TB disks installed in the NAS.

I tried sometimes but then I left because I don’t want to do some sh*t in the system.

The RAID 1 of the old disks is ok, the system told me that.

I talked with the WD technical support and they told me “it is normal that the system sometimes does not recognize the old disks”.

Kind regards,

You must be joking?
The system might not recognize old disks??

There are MANY points of common mode failure in a NAS box.
Being able to remove disks from a dead box into a new box is base system functionality for a system meant to act as a “backup”.

If this is true; I suggest you seriously rethink your backup strategy. (I did that step a while back)