Cloud Access - cannot be permanently disabled


#1

Cloud Access - settings automatically changes:

Steps:

  1. Disabled Cloud Access via dashboard
  2. Ran My Cloud on the mobile device. Gave appropriate password.
  3. Cloud Access automatically gets enabled on Dashboard!!

Why Cloud Access is being turned on, on Dashboard when disabled it?
How can I prevent Cloud Access turning on?


#2

Hello there,
Try to do a reset on the device to see if this helps. Please check the following link for help with the reset process:


#3

That was the first step I did :slight_smile:
It happens with even with newly created users.


#4

I have the same issue. I do not want Cloud Access activated. I want it permanently OFF


#5

I have disabled cloud access several times. After doing so, I have checked when outside my LAN and verified it is off. However, subsequent checks reveal that it is accessible again to external users. I restart my device periodically to modify advanced settings requiring a restart. Can a restart reactivate remote access?


#6

HOLY SCHMOLY!!!

I went into my EX2 Ultra Dashboard (from machine). . . Verified under “Cloud Access” that “Cloud Service” is off.

Logged onto Mycloud.com. . . . .and I have full access to files on the NAS.
Verified on the iOS app. . . I have access to the NAS via the WD app.

This sounds like a pretty major security bug

I have double checked - - -port forwarding on the router and the NAS box is “off”. I am pretty sure that would stop other things from getting to the NAS. (But who knows?). Firmware for router and NAS is current. Pretty sure that if I pulled the network cable, that would work. BUT. . .I still want the machine visible to other machines wired into the home network.

OK. . . How do you hide a WD NAS from mycloud?


Update: Played with setting and figured it out

It appears that turning off “Cloud Access” under Settings --> Generally stops you from authorizing remote users either from the Dashboard OR from the WDCloud website.

It does not stop already authorized remote users from logging in and accessing files.

Under the “cloud access” tab of the NAS dashboard, you can revoke permissions to the users you have already granted access to. THEN those users will be blocked. But turning off the “General - - > Cloud access” does not.

So. . .I authorized a few users on a few devices 13 months ago. I turned off cloud access probably 12 months ago. . . but never revoked access. So today - - > I logged into the WDcloud with no trouble at all; because I used accounts that I had already authorized.


Not clear what “Dashboard Cloud Access” button does. I suspect that this will disable the dashboard if you are accessing the NAS via a web browser from outside your local network (I am not going to experiment in the rabbit hole just now).


After an hour of sleuthing. . . I have not figured out a way to positively block all internet traffic to the NAS box. . . since it is clear that WD will try to keep certain ports open for its features to work as advertised.


MORALS OF THE STORY:
1) Cybersecurity is hard. The only way to be secure is to cut the cable.
2) The WD.COM cloud is a managed backdoor into WD NAS units (. . .and probably your network)(just like everything else on the computer)

Even if you block most means of access from remote systems into your network, the WD cloud can get in. The advantage is that you don’t have to be Network Guru to get access to your NAS boxes from outside your network (trust me. . .it ain’t easy to set it all up). The disadvantage is that the door is only as secure as the WD programmers. The last firmware update or two has been all about securing this (and a few other) doors.