Clean OS (Debian), OpenMediaVault and other "firmwares"

Of course, just be patient because I’m not in office these days. I’ll send you pm asap. Goodbye

please dont forget!

Finally I had time to come office and upload them.

  1. unpack tools as usual on a thumb drive
  2. make a folder in the root dir named “backup” (without quotes)
  3. bootup the nas as usual
  4. launch restore-emmc.sh (or ./bin/restore-emmc.sh)
  5. enjoy the original firmware :unamused:

Let me know if they work (for me they’re ok).

today i restored using your backup. it worked! i have to deal with original firmware yes, but at least im not stuck in the bootloop of omv.

really thanks!!

For those using Clean Debian Jessie image WDMyCloud-Gen1/Clean%20debian/CleanDebian-Jessie.tgz, I’ve just gone through this exercise while resetting my myCloud with the new 18TB (currently using a split partition due to Linux 32-bit limitations), you may notice that running run_me_after_reboot.sh is probably not working properly.

Due to the time passed since, Debian Jessie is now out of support and so this includes APT’s ability to function using the defaults.

To fix this, you’ll need to do the following:

  1. Probably try running apt install debian-keyring debian-archive-keyring first if it works.

  2. Update /etc/apt/sources.list to include the following entries:

deb http://archive.debian.org/debian jessie main contrib non-free
deb-src http://archive.debian.org/debian/ jessie main contrib non-free
# Up to you if you want to continue using stable or comment/delete/keep whatever else.
  1. Since the WD myCloud NIC does not support IPv6, you will need to turn this off permanently. Create a file using nano /etc/apt/apt.conf.d/99force-ipv4
    Then put the following contents:
Acquire::ForceIPv4 "true";

Save and close.
Note: You may consider adding other settings if you really can’t deal with the GPG auth issues, but you can google that yourself as it’s at your own risk.

  1. Once all good, try running apt-get clean && apt update and see if you’re able to proceed further with the run_me_after_reboot.sh script.

Hi CarabouSpider

did you figure your problem out?

I had to reinstall my wd mycloud gen2, but it doesn’t connect (no ping, no ssh).

Couldn’t install it form USB stick, had to open it and copy the files to the hard-drive. (uImage, uRamdisk and jessie-rootfs.tar.gz).

Did something change? The manual doesn’t work anymore, or i got dumber in the meantime :wink:

Help would be appreciated

Also probably a dumb question, a usb stick, fat32, with uImage, uRamdisk and jessie-rootfs.tar.gz on it.

Why does the NAS sometimes boot from the USB-stick, but most of the time not. How can i influence that behavior?

(how does the reset button, 5 seconds and 40 seconds influence that or not)

No @evil77 , unfortunately not. The reason why I tried to install the Debian Jessie image is to be able to run my new 18 TB drive in my Gen 2, but eventually I gave up and bought an older Dell desktop and installed TrueNAS and reverted the Gen 2 back to the image I made of the My Cloud OS it had. Through all this I got actually pretty good and quick at loading images back and forth… :laughing:

You should be able to use an 18TB drive, but you will NOT be able to use a SINGLE partition larger than 16TB (Since these units are armv7 which only run 32-bit Linux). You need to split them.

Understood, and thinking back that is what I ran into. The MyCloud OS couldn’t recognize an 18 TB partition if I forced creating one after removing the HDD and installed it in a PC using a Linux distro. And that was when I realized the 32-bit limitation (kind of a duh moment) and that the armv7 was obviously 32-bit. So I figured to just buy a Dell desktop PC to run TrueNAS instead and be able to run Jellyfin, Home Assistant etc. that would not have been able on the Gen 2.

What i figured today;
the reset button seems to only work on WDs original OS, not on debian.
With debian the reset button seems to not have any function.

WDmyCloudGen2 seems to boot from USB stick if or when sda3 is missing or empty, probably when it can’t find uImage or uRamdisk.

Did a fresh install today, can’t access it. No ping, telnet or ssh. after 1-2 hours the router doesn’t display the IP anymore (it takes probably time till the router forgets the connection/IP from the time i accessed it with telnet)

That is strange because i did everything the same way i did it a few years ago

i made a recovery to original OS with
https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt

set it up to access, copied necessary files on it for debian, installed debian according to
https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Debian/_howto_en.txt

and got the same problem, no network access. (no ssh, ping etc.)

so maybe the new downloads (files) are broken or not the same as they have been bevor Fox_exe took them down two years ago?

Hi,
I have a my cloud home duo, could I use Fox_exe 文件 |/WDMyCloud/WDMyCloud-Home/Debian/ 的内容 (fox-exe.ru)on my device?
and Where should I start? Or check out the guide?

please help me

I really should have checked the previous replies first but there are 1912 of them which is way too many sorry

I have the My Cloud Home with OMV installed.

Now I want to go back to the original firmware, but if I read correctly WD doesn’t provide one.

What is the best strategy back?

The My Cloud Home is an entirely different device than the My Cloud line. It uses a different operating system than the My Cloud line. You should ask your question in the dedicated subforum for the My Cloud Home and hope someone can answer how to restore that device to it’s original firmware. Do not attempt to use methods to restore the operating system to the single bay/single drive My Cloud units on a My Cloud Home unit.

1 Like

Devuan 5 (fork Debian 12) and Gentoo for MCG1