Cineamanow showing outdated library


I’ve had my wdtv plus for some time now, but just the other day setup an account with Cinemanow.  I liked the idea of an alternate provider to netflix which is accessible in Canada as there are so few options up her.  I got it all activated no issues and was even able to rent/download an older move on my wdtv

However, when I go to New releases it shows outdated content, movies that have not been new to dvd for over a year.  Comparing to cinemanow’s website with the current new releases they actually have new movies there.  For some reason my wdtv plus is pulling an outdated list/movie inventory from cinemanow.  Even searching manually only has older movies and not their current stuff.  Has anyone encountered this issue?

I’ve tried the latest 1.06 firmware and rolling back to 1.05, same issue

On a possibly related note (or not) when I went to activate the device with my account it pointed me to

when in fact the current (functional) url was

Is it possible some url or server/page name for loading the available movie library is also outdated in the app? If so how could I get around this?  Or is there a totally different cause for the outdated content issue?


I don’t think the movie catalog has something to do with the WD TV 

You wouldn’t think, but I already talked to cinemanow and they have had no reports of this issue on other devices, so it would appear it is realted to wdtv live pro hd

Out of curiousity can someone else with a wdtv live pro hd open the cinemanow app (you don’t need an account to just view it) and check if the movies under new releases are new for you (as opposed to 1-2yrs on dvd already)?  I’d like to isolate if this is an overall issue or just something in my environment.


Tuesday (today) is new release day. I see “21 Jump street”, “project X”, and a few others. All new releases… You are looking at the correct category, right? The “new arrivals” section?

Thanks Tony,

yep, thats where I’m looking.  Must be something environmental - wonder if this app uses some port on my router i gotta unblock or something, can’t think of much else that could be breaking this- anyone know off hand what ports it might use?  or maybe how to reinstall this single app on my box? (I have done firmware flashes but those had not effect)


well, its not my router, I know that much, hooked it straight into my modem, same effect

is there any way to remove all remnants of the cinemanow app and reinstall it?

Let’s go back to the beginning.

You mentioned that you think the URL provided is incorrect.

Actually, IS the correct URL, but it appears that URL redirects to the same URL you provided, so I don’t know if that could have made any difference as to which portal you used to activate the device.


Yes I orginally tried and the page is active and seems correct, but it does not work when you try to sign in, it redirects to even if you are already authenticated, but will not accept a login (From a Canadian account anyways) After speaking with Cinemanow support they directed me directly to the url I mentioned which worked first shot with the same credentials I was trying on the other page.

The device is activated now and as I said I could rent/download an older movie successfully.  I doubt this is the issue anyways as even if your box is not activated with the service you should still be able to see the current New Releases, which I couldn’t even before I activated with Cinemanow.  Running out of ideas on how to fix this… 


Update on this - I am convinced th issue is not the wdtv box now - I rolled it back to a firmware before cinemanow was on there, and then updated it again to the latest, basically uninstalling/reinstalling the app

On top of this I discovered Cinemanow was available on PS3 so I loaded the app there and Saw the SAME BEHAVIOR with only older movies showing under new releases or coming up in search results, even before I activated with my account, to me this means there must be 1 of 2 possibilities:

  1. Some fundamental issue with Cinemanow working on external devices in Canada (it does however work from their website on a pc)


  1. My ISP (Rogers) could be blocking this traffic somehow (this would be really sketchy I know but they do sell their own video service)

I also doubt its an account issue because it occurs even before you activate the device to an account.

I’ll need to take this thing over to a buddies house with a different ISP (but still in Canada) and validate if it works from there.