Change SSH FileSystem from read only to write?! Twonky


New to the site and new owner of the pr4100, liking it so far.

Basically my problem stems from my panasonic tv not displaying my files in alphabetical order, something which I have searched and seemed to found the solution for - I need to edit one of the panasonic xml files in the twonky folder.

However I cannot edit it - it get a warning message along the lines of - cannot edit file - file system is read only.

Ive tried editing the file, deleting the file, renaming, even right clicking on it and trying to change the r/w/x ticks but it wont let me do any of them.

Ive traced it back and basically it wont let me edit anything inside the twonky folder, the previous folder I can actually right click and change the r/w/x ticks - doing that still no further forward.

People have done it so it must be possible somehow - I’ve seen a few others with the same problem but no solution thus far.

original post - Panasonic TV DLNA Sort Order

Any help much appreciated because its driving me up the wall!

Don’t use twonky, you can’t edit the config as it is part of the squashfs image…
You could build your own image.cfs, but that’s not that simple.

I suggest you install Plex, it also includes a DLNA media server and I’m pretty sure you can modify some of its settings.

Or install entware and get the gerbera package with opkg install gerbera
Entware has many dlna options but gerbera is currently maintained.