Caution: Hidden Registration? - How My Cloud device activated Cloud Service and treated me as registered user

I just bought two My Cloud devices (EX2 Ultra), although I have to admit I was very sceptical about WD beause of

  • the “back door incident” and especially the period of time to get it fixed
  • the lack of information regarding Cloud Service Access from the internet. I just could not find detailed information on how a user registration for My Cloud would work technically (i.e. would all data run through WD servers or not; would WD be able to access my files …).

As far as the latter, I was irritated by the information that apparently one could not use the My Cloud mobile app to access one’s files

  • from within the home network (wifi) without registration

  • from the internet/mobile data via a static IP / a dyndns-service without/instead of WD My Cloud registration.

It seemed very strange that a manufacturer would promise you an independent, private home and at the same time making it mandatory to leave a set of keys with them.

I bought the NAS anyways, with the intention to not registering and not activating cloud access, and just using the NAS as network drives.

So I set up all users WITHOUT entering an email address.

In the settings, I switched off “Cloud Access/Cloud Sevice” completely.

Setting up the network share as network drives worked fine.

Then I tried to find out if I could access the files with a handheld from within the network (wifi). I installed the “My Cloud” app.

I did NOT register or sign in on the second setup page. Instead, I clicked “Add device” (translated from German).

On the next page, my device was shown and I selected it.

After that, I was being promted for a user. I used the user “temp” and the according password.

I skipped the prompt for photo and video backup (not now / later):

In the end, I was very happy that it worked and apparently I had found a way to access my lokal NAS files without registration with WD!

My next thought was that maybe it would also work from the internet with VPN. But after turning WIFI off, I discovered that the My Cloud app already had access to my files from without the home network. I was very confused. I switched off the “Cache” function, but could still access my files at home. How did the app know the IP of my My Cloud NAS standing at home??? I then checked the My Cloud (NAS) settings and discovered that in general settings, “Cloud Access/Cloud Sevice” all of a sudden was switched on and in the Cloud Access settings I could read my email address WHICH I NEVER ENTERED!

I did NOT change the Cloud Access settings and I never, at no time, enter my email address!

I then checked if I could log into files.mycloud.com. I could not. I also could not reset my password.

I know that I deliberately used the My Clound app, but since I skipped registration and since I never entered my email address, I am afraid that apparently WD created a “hidden registration” for my device. Before I call this a serious data privacy and security issue (and probably return my devices), could anyone please try to replicate the procedure as described?

Thanks!

@Santelmo Did you know that you were placing this in the WD My Cloud sub-forum? WDMyCloudImage

The owners of the My Cloud EX2 may be interested in this too.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2

You said, " I also could not reset my password."
See if this helps with your password.

@Santelmo

Please review to the following article