Casting and USB media problems with WD TV Play


#1

Hi, I got myself WD TV Play with main intention to use for casting movies from my tablet. Unit goes via setup, has picture, menu etc, on that part everything works fine.

The first problem occured when I tried to use some casting apps like All cast and Localcast. They recognise and connect to WD TV without problem, but when I try to cast some content, like movie or images, I can see them loading on TV screen and then it shows just blank black screen with white caption of media file. When I flicker through images, you can see some change on TV screen, but once again, nothing is loaded. Only app I managed to get anything from was Localcast, it only start to work when I launch one .mkv movie, then it start to play them all if I use ‘next’ or ‘previous’ control buttons. For some time, player controls work, then only play and pause buttons respond. I tried various other casting apps and everyone got more or less same problems. I read on another forum about need to unplug WD TV from power and once I managed to get image from gallery working on Allcast, but after I flickered two or three, image disappeared. I wonder if that is pro lem with these apps or such behaviour is related to unit itself?

After that, I tried to use My Storage for playing directly from USB stick, I had some movie files there - USB was mounted, found but when I launched these files - mostly .avi in MPEG4, audio was going OK, but no picture. I did power unplug, then these files started to play OK. I decided to add new files to the stick, connected it again and from now on, it doesn’t show any media files on then, detects old files but doesn’t refresh and show any new added movies or images.

I tried to reflash with latest firmware, got USB stick again, but firmware files on it, followed the procedure and once again, no any new files were detected.

So, based on all that, any steps I can do before returning the device back? Is that just coincidental circumstances with casting apps and USB stick while WDTV is ok, or maybe somebody had similar issues?

Thanks.


#2

Hello,

I have never tried this. Lets see if any other user has tried this before and can share their experience with us.