Can't update drive firmware for my WD My Book Essential 1.5 TB


#1

I followed all the instructions to update the Drive Firmware found on this page: http://www.wdc.com/wdproducts/wdsmartwareupdate/firmware.asp?pid=1110&os=WIN I disabled the anti-virus and anti-spyware programs, all programs turned off and, after downloading WDSmartWare_Software_Upgrader_for_Windows_1.4.5.2B and unzipping, disabled/disconnected from internet/network connection, before clicking on WDFirmwareUpdater.exe. The only external drive connected is the WB My Book Essential which is the one I’m trying to update the drive firmware for. When I try to update the firmware I keep getting the message: You may only update one drive at a time. Safely unplug all drives with the exception of the one you want to update, then click rescan. I don’t know what else to do to be able to update the drive firmware. Please help. Thank you


#2

I am having the very same problem.  Welcome any assistance to overcome this issue.  Thanks


#3

Same firmware update problem here.  Any help out there? 


#4

Have you try to update on a different usb port or a different computer?


#5

I am having the same exact problem.  It’s aggravating.   I did reinstall Windows 7 before I ran this update but the external drive was and is working fine.  I just can’t do the update.

Thanks for any assistance anyone can provide.


#6

#7

I get a message that there is more than one drive connected, when in fact there is not when I try to update firmware.   I was able to update software but not firmware.  I think this drive is going back.  Please advise if you hav a solution.


#8

Same exact problem!!!


#9

My solution :

In Device Manager, Expand “Universal Serial Bus Controllers”

There I disabled all Usb Root Hubs that have any “attached devices” under Power sections.

After that the Update Driver worked.

After that i enabled one after one. And the one who stopped the firmware update

was “HP Integrated Module with Bluetoot2.0 Wireless technology”.

Hope this will help some of you,

Enviroment :

Windows 7 x64

HP 8530W

/Tony


#10

This issue has already been addressed in the link below.  And we are looking into this.  For now, please disconnect any HP printers before you update.

http://community.wdc.com/t5/WD-Smartware/New-Release-Universal-Firmware-Updater-for-Smartware-Supported/td-p/163566

Edit

If you’d like to help, go to that thread and post what model HP devices you have.  That will help our engineers.