Cant setup WD Mycloud device, error on configuration page

I bought this device from a reputable eBay seller a couple of weeks ago.  Since I received it I have not yet been successful at getting the device setup properly.  I’ve reset it numerous times and tried with and without a hard-drive installed.  I am stuck on the configuration page that gives me the error:
Fatal error: Call to undefined method DateTime::getTimestamp() in /usr/local/modules/web/pages/index.php on line 35

The device is connected via a Linksys E1200 router.  I’ve also tried configurating it with an ad-hoc connection to my laptop.  I downloaded and ran the WD Discovery tool, it picks it up on the DHCP configured IP address although I still can’t configure the device, even using the Configure command on the WD Discovery Tool.  I get the same error as described in the thread when it opens about a missing PHP function. 

I’ve contacted WD Support but they are absolutely useless, it takes them 3 days to respond to my ticket via e-mail and the advice they give me is of the 1st level kind ie. “Is the device plugged in Sir?”.  I’ve decided to give WD a chance after being a Seagate guy for years. With support like this I’m having second thoughts about continuing my relationship with this company.   Samsung seems like the next logical step.  This is my support reference number for follow up WD Support [Deleted]

For your convenience this is the output given the device’s reporting daemon


<root xmlns="urn:schemas-upnp-org:device-1-0"> <specVersion> <major>1</major> <minor>0</minor> </specVersion> <device> <pnpx:X_hardwareIdxmlns:pnpx="">VEN_011A&DEV_0092&REV_01</pnpx:X_hardwareId> <pnpx:X_deviceCategoryxmlns:pnpx="">Storage.NAS</pnpx:X_deviceCategory> <pnpx:X_compatibleIdxmlns:pnpx="">urn:www-wdc-com:device:NetworkAttachedStorage</pnpx:X_compatibleId> <df:X_modelIdxmlns:df="">{02BF98D2-1B50-4a1f-83D9-A85402782903}</df:X_modelId> <df:X_containerIdxmlns:df="">{73656761-7465-7375-636b-0090a9f65001}</df:X_containerId> <deviceType>urn:schemas-wd-com:device:WdNAS-DEV_0092:1</deviceType> <presentationURL></presentationURL> <friendlyName>WDMyCloudEX2</friendlyName> <manufacturer>Western Digital Corporation</manufacturer> <manufacturerURL></manufacturerURL> <modelDescription>WD My Cloud 2-Bay Network Storage</modelDescription> <modelName>WDMyCloudEX2</modelName> <modelNumber>KC2A</modelNumber> <modelURL></modelURL> <serialNumber>WNQ244802032</serialNumber> <UDN>uuid:73656761-7465-7375-636b-0090a9f325f8</UDN> <serviceList> <service> <serviceType>urn:schemas-microsoft-com:service:NULL:1</serviceType> <serviceId>urn:microsoft-com:serviceId:NULL</serviceId> <SCPDURL>/empty.xml</SCPDURL> <controlURL>NULL/control</controlURL> <eventSubURL/> </service> </serviceList> </device> </root>

I believe it would be best to replace the device in this particular situation. This is because in case there is an issue with the Dashboard, SSH will be the tool to use to correct it. However, SSH needs to be enabled after the initial Dashboard setup.

I managed to get it functioning.  For anyone that runs into the same problem, I followed advice from another person in this forum that had a problem with the device that was stuck in Safe Mode.  Suppot advised to unplug the lan and power adapter, then hold the reset button, attach lan, then power adapter and keep holding the button for 40 seconds.  Seems like this does another type of hard reset that’s not included in the documentation.

1 Like