Can't see UI after changing to Twonky but drive is visible on my network

Hi There, 

The other day I decided to go back to Twonky media server (via the official upgrade). I can now see Twonky from various media devices but when I try and access the WD UI , I get a page saying “This web page is not available”. The drive itself is available and can be seen on the network and I can connect to Transmission and connect via SSH using Putty but can’t see the WD interface.

I’ve tried restarting the router and the drive itself as suggested in other threads and neither has worked. Any help would be greatly appreciated.



Hi ilikecake, welcome to the WD Community. Did you My Book Live came with Twonky or DLNA installed? 

Hi jubei04, 

To be honest I can’t remember. I think it came with DLNA but I did switch to Twonky via the official GUI official upgrade.

Any other ideas anyone? I’m assuming that the a service isn’t starting properly when it starts up but not sure which one. 

Can I manually apply the dlna firmware without the UI interface?

Ok, I have SSH enabled so I followed the instructions here to try and reapply the DLNA firmware manually

After rebooting, the drive once again appears on the network and is accessible but the UI still isn’t accessible. The problem is you can’t manually download the firmware from the WD website anymore, just the media server atches. Anyone know where I candownload the latest, complete firmware from?

check de debrick guide V1, it has the links to fimrware versions.