Can't see computer on WDTV Live

Hi Guys,

Purchased WDTV live earlier this week and really feel like throwing under a fast moving truck…

I can’t seem to get WDTV to see my PC but i can see WDTV on my network through my PC. I can even stream a video direct to the tv by right clicking on it, selecting play to, and then WDTV and it streams fine.

I have followed just about every trouble shooting video and forum i could find and still can’t manage to access my video library from WDTV.

When i go to the video library on WDTV, then select Network Share, it finds “TELSTRA” who is my ISP so im assuming it is talking to my router. When i select that it asks for a username and password. From all the videos i have watched it looks as though i am meant to see my computer name there.

Any help would be greatly appreciated.

I am going to assume you have a Win 7 PC.  Your PC and WD player must be in the same work group.  In most cases the default name for the PC is WORKGROUP.  The default for the WD unit is the same, so check that they are same.  Look on PC under Control Panel/System.  If the name of the PC workgroup is not WORKGROUP, change it.  ALL devices on the home network that share with one another need to be in the same workgroup; in this case the one named, WORKGROUP.

If you do not have a complete manual on a CD, then go to the WD Support site and download it.  You need it to set things up right.  Give it another try with this info, and if you get stuck, just call WD Support.

The fact that you are seeing TELSTRA, your ISP when you go to connect drives would worry me. A standard setup would be the Internet coming into somesort of device (a modem), and that going into a router that divides the Internet from your internal home network. I would not think (or want) Netbios Names (such as your ISP) to be broadcast from the Internet side to the home network side and vice versa.

Assuming your router is protecting you with some sort of basic firewall services, it should keep all name service broadcasts from clients and your master browser on your home network. Seeing the ISP name on your home network may be an extreme security issue.

Note that I do not have experience with either Telstra or any other standard setup in Austraila (where I believe you are), so I am just comparing to what you usualy see in the US.

======[MODEM]===[ROUTER]==[Home Network]

so is your setup similar to this?

If so

  1. Can you access internet services from your HUB?

  2. Is there anyway your Router is named TELSTRA and broadcasts messaging? Logging into it should tell you that. Generally routers do not broadcast their names in that way but I guess it is possible.

  3. If you are getting netbios broadcasts from the ISP side, I would call Telstra and get help closing off you home network from the nasties on the Internet. If you are not open on purpose and setup a DMZ for a reason, you want to close of this risk as soon as you can.

I know you said you have read all the board stuff you could find. Did you read the excelent post below by TonyPh12345 called “Troubleshooting Window File Sharing”? I have a lot of Master Browser problems on my own network that can cause similar issues, so if you have not read, I woud go through the steps he outlines.

Let us know how you do


Hi guys,
Thanks for the replies.

Yes I am running windows 7. I have checked the workgroup and they are both the same. I have checked to see if my computer is master browser and it is. I will try the linked process and let you know.

Ok so i ran through that trouble shooting and this is what i found.

On the first set of commands i only could see my PC and no WDTV. Would this be a problem as i can see the WDTV through my networks under the media device tab.

So i continued to run the commands and could only see 1 other thing that was different to the person who posted and that was the second command (nbtstat -a user-pc my PC is called user PC). Untitled.png

As you can see i have 2 workgroup’s at the bottom and 1 is listed as “Unique”. Could this be the problem and is there a solution?

Not sure why you would not see all your devices when using “net view”. You certainly should. I believe the Master Browser resonds to that request and give you a device list. Could be an issue but I am not sure where you go from there. Does not make sense to me that the master browser (your computer) cannot see the HUB with “net view” but can via the standard interface. Should be the same for both.

Are you absolutley sure that the two machines are in the same workgroup?  With the Win7 interface it can be tough to tell. In general i would say use the net view command to determine that (net view /DOMAIN:WORKGROUP) but you are saying that net view does not see the HUB so I am not sure of another good way besides rechecking your spelling etc.

As for your second comment, that is fine. The master browser (indicated by _MSBROWSE_) will show you the workgroup as both “UNIQUE” and “GROUP”. Your other machines will not and just show the workgroup twice as “GROUP”.

Hopefully someone else can chime in here with some ideas. I would certainly try re-booting all network devices including your router, and also change up the order. If you boot your HUB first, it should take over being the master browser, and then boot the PC. See if that make a difference.

I have a similar issue that I have been working on for quite some time. I have tracked it down prettty specificaly (and I wont go into it here, it’s for it’s own post), but when I do a specific thing on one of my PCs, the HUB can no longer see it untill I reboot the computer. The computer can always see and copy to the HUB. I have not solved the issue and have been resorting to rebooting the PC when nescessary. In my situation it appears to be related to something on my network and not the HUB but I am pretty stuck. Very frustrating

Good Luck



I prefer to use a less geeky approach than net view to locate the master browser. 

Check on the status of the master browser:  see this link, and download and use the free program there:

Screenshot of my lanscan test; compare it to net view:

Lanscan Capture.JPG