Can't see all files on my NAS server via 'My Media Library'

I’ve had my WDTV Live SMP for some 6 months now and all has worked a treat. I have had a few little problems and frustrations but it is usually me getting to know the system. Until now.

I have a HP NAS server running Ubuntu that I keep all my completed movies and tv series on. Every few days I add more content to the server which has a folder for TV-Movies and 6 folders under that. 2 of those folders are ‘New TV Series’ (contains 19 folders) and ‘New Movies’ (contains 33 folders).

2 days ago I noticed that I could only see 16 folders in the ‘New TV Series’ folder and 31 folders in the ‘New Movies’ folder if I accessed them via Files or Videos in My Media Library. I have done multiple rescans and restarts but no change. The folders missing are the latest ones that i have added.

If I press the Red button and ‘Select Content Source’, ‘Network Share’, ‘Windows Shares’ and Ubuntu (which is my server) I can see all the folders. But if i ‘Select Content Source’ and ‘My Media Library’ then some of the folders are missing.

I am running version 1.15.10

Very frustrating and I’m hoping there is a simple answer.


Is it always the same folders that “go missing,” or is it random?

If it’s always the same, is there anything different about the names of those folders? — and may sound like a dumb question, but do the missing folders actually have compatible videos inside them?

Yes it is the same folders and it’s the latest folders that i have added. And the videos are compatible because I have them on my PC. I keep the videos on my PC until I make a complete season and then transfer them to the server. In this case I couldn’t see them on the server so I watched them from the PC.

You mention above that you’ve tried multiple Rescans and Restarts – have you tried just clearning the media library and letting it rebuild it?


So if I delete the folders in the media library and then do a restart, it should rebuild the media library?

I was able to get it to work by deleting the .wd_tv folder in the problem folders and then doing a restart. It found the missing folders but it sure is not something I want to do every time I add a new folder. And it obviously didn’t fix the problem because I added a new folder and did a rescan and it did not appear in the list.

probably the quickest way to resolve

turn off media library

clean media library

turn media library back on

let it build media library

or just stop using media library

access the server via samba or linux shares = no database to try and maintain

The architecture of the wd_tv database is a bit of a mystery.

I think you might want to try it from the UI – Setup / System / Media Library / Clear Media Library

… and see how that goes.  Deleting folders manually might be a bit hit & miss.

Thanks for your help fellas, much appreciated.

I did a Clear Media Library and that seems to have solved the problem.

I added a new folder and did a rescan and it was added to the Media Library so all seems to be working.

But I will be keeping a close eye on it. :smiley: