Can't play any videos after pressing stop on remote

 I can’t play any videos after pressing stop on remote, for example if I selected the wrong episode of a tv show i press stop on my remote and select the other file and I get the blue circle loading thing with the first tv episode I originally selected playing the background almost like it didn’t really stop it.

On the other hand if I let it play all the way to the end it’ll bring me back to my menu and I can then select any video file and they will always work, it really is just when I press stop on my remote, find it a pain to have to reset the media player if i press stop.

I am running Windows 7, wired connection via WD live wire, WD TV live 1.04.22, D-link 625 router.

Any help or suggestions is welcomed.


Hmmm.  Are you using the MEDIA SERVER function? 

I’ve tried using both media server and network share and they both give me the same problem, but looks like i ain’t alone, found this.

I don’t think my problem is a network problem since I try to play my videos from a usb stick and the same problem occurs.  Not sure what else the problem could be but the firmware but if it’s working for most people it can’t be that.

I might try again playing some movies from usb stick but only after reseting to default and pressing the switch on the side since i didn’t try that when I tested it from usb yesterday.

If anybody has any suggestion, I’m all ears.


When you’re playing it from a USB stick, try disconnecting the Live’s network cable.

Yes ok I will try that tonight, very good point. 


So i re-tried playing video threw my usb stick with the lan cable disconnected and sure enough everything worked, I was able to stop any video and start a different one withought any problems and also noticed that I didn’t have to wait 5 mins or so until I was able to pause, I was able to pause right away.

So its defently something with my network.

Any other ideas Tony?

I think you’re suffering from the same issue that others are having with devices that are doing UPnP like the Virgin SuperHub and a few oth devices.

Ya I’ve read about that but I’ve tried disabling the UPNP feature in my router and problem still there, can’t play another video after pressing stop on remote. 

Well I finally found my problem, turns out I had to DISABLE MULTICAST STREAM in my router.  I can now pause the movies right away, stop them and play a different movie withought having to reset it.  All is good, I love this media player now the only other thing I would like is to have a checkmark for the tv shows or movies you’ve already watched. 

Here’s some info on multicast stream that I took from my router.

Multicast Streams : The router uses the IGMP protocol to support efficient multicasting – transmission of identical content, such as multimedia, from a source to a number of recipients.

Enable Multicast Streams This option must be enabled if any applications on the LAN participate in a multicast group. If you have a multimedia LAN application that is not receiving content as expected, try enabling this option.

Thanks Tony for all your help, it’s very much appreciated.