Can't Output a DTS signal after update using Digital setting

Hey Guys, since 1.04.10V I have not been able to output a digital signal over HDMI. Before this update, I would get a DTS signal when the media being played contained that signal. But now I get absolutely no sound at all when I select digital output using HDMI… Am I missing something? I have tried a reset. On some articles I read it said to reset all the upstream components also as the WDLIVE may have sent an improper signal to the connected hardware. Is this an option? Any help would be appreciated… Free-

Did you ever find a solution for this issue?

Can you describe your setup a little more?  Are you still using 1.04.10_V or did you upgrade to 1.04.17_V?

E.g.  are you connecting via HDMI to a receiver, or via HDMI to a TV and then to a receiver?

I have my Live (running 1.04.10_V) connected directly to my Pioneer amp.  

Audio is set to Digital.  The other Digital option is Digital without HDMI, which is obviously not the one you want.  ;)

When playing MKV files with DTS audio (streamed from a NAS running Twonky Media Server), I get a clear DTS signal to my amp.

Have you tried a factory reset on your Live?  Try the 3-stage (“overkill”) reset, as described here: