Can't map MyCloud: not shown

#1

Hey there,

trying to map my MyCloud under Windows 10. It is shown under “Network Addresses”, but I can only access my media folder there. When trying to map the device it is not shown…

Any idea?

Thanks!

#2

Sounds like you have the same problem many others have with Windows 10 and the My Cloud not showing up properly. See the first tacked thread of this subforum…

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

The way to manually map a share if the My Cloud doesn’t show up properly in Windows File Explorer is to use \\wdmycloudname or \\mycloudipaddress in the Windows File Explorer address bar which should open up the My Cloud and allow you to right click on a Share/Folder to select the map network drive option.

#3

The other day all of the devices on my network were listed under network in file explorer. Yesterday and this morning most were not listed. Now they are all back. I put the laptop to sleep earlier. When I woke it up it rebooted.
Not sure why.

RAC

#4

Not sure why either, although there is a solution for this I recently posted in another thread nere:

. . . any version of Windows issue. On both my Win 7 and Win 8 laptops my My Cloud (and any other devices) can disappear from my Network listing for some reason or another. So, on either PC, I just refresh the Network listing in Win File Explorer by clicking cursor into Network, and hit the Refresh Network button; at the top of the screen near right side there is an up and down arrow for Win 7 or a curved arrow for Win 8, and most all the time all devices show back up. These refresh arrows can refresh any other category, too, for example if cursor is in Computer, it will refresh that section.

On rare occasions if this doesn’t do the trick, I may need to reboot my router and PC, but not often.