Can't login to My Cloud on local network using iPad app (Windows 8 laptop works fine)

When I click on the local drive found in the iPad app it does not allow me to set the username.  It just displays my first and last name (I may have set the iPad up this way) which has a space in it.  For example, it says the user is Bill Hewlett but I set up my drive admin username as Bill.

When I give it the password for my one and only user on the WD My Cloud, it says no good. 

I have other issues with getting to the internet (it claims) so I cannot set up Cloud access but I really don’t need that.  So far all seems good on the local network except the iPad is useless.  My TV eats the content fine.

Any help on getting the iPad to work on the local network would be great.


More info:

I created another user using the dashboard named Iggy which has no password.  When I launch the iPad App, it sees my drive on the local network.  When I press the + sign next to the drive it gives me a choice of my name with a space in it and my new user named Iggy.  I click Iggy it does not ask for a password and it says:

Unable to connect to device.

Please verify your password and try again.

So, this tells me that it is not the login name nor the password but for some reason, the app cannot access a WDMyCloud from the “Found in Network” list.

Does anyone know of a setting change that needs to be made in the Dashboard to get this to work.  My cloud currently does not work outside of my local network and I don’t think I want to open it up anyway.  I would like my iPad to be able to access the drive so it would be super if someone could give me a hint as to what I need to do to get this to work. 


P.S. I should mention that I’m able to access my Microsoft Skydrive using the iPad app with no problem.

As far as I know, you cannot connect to password-less users.   Set a password for the user and see if it works.

If you don’t want to set a password, then use the Device Access Code method to pair the device instead.

I tried a user with and without a password and it did not work.  I can’t get the access code because my cloud cannot get to the internet because I don’t want to fiddle with my router and I’m not real interested in allowing outside traffic access to my cloud.

It seems that the app does not work on a local network if the cloud cannot be accessed from outside the network.  Can someone confirm or deny this statement?

It would be nice if I could get this to work.   My TV, wireless windows 8 laptop and wireless windows 8 deskside computers have not trouble getting at my cloud on the local network.  Just the iPad using this app.

trossin wrote:

It seems that the app does not work on a local network if the cloud cannot be accessed from outside the network.  Can someone confirm or deny this statement? 

If you’re only accessing it locally, then you don’t need the cloud app at all.

There’s plenty of free apps out there that can connect to your NAS such as File Browser.

I tried the free File Manager app from Tap Media Ltd. and it did not work either.  I had to configure it to use ftp access, which I enabled on the dashboard, but it still would not connect.

I also tried a few other file managers with no luck.  most wanted money to use the WiFi interface.  I should not have to pay to get access to my new cloud drive because the WD app does not work when the network is not opened up to the entire internet.

Then you have other problems – I don’t think you’re using it right.

I have no problems using any of the apps I’ve downloaded, yet you’re having problems with EVERY app you’ve tried.

I think the problem is with your setup, not the Cloud?

Can you be more specific about not using it right?

Using the WD app on an iPad 2:

  1. I click on the drive found in my local network.

  2. I am given a choice of my two user accounts on my drive and have selected either the one with a password or the one without.

  3. I enter my password if prompted for the one that requires one (I typed it in correctly)

  4. It thinks of a number and then tells me that it cannot connect.

If I do this on two different Windows 8 computers using the WD My Cloud desktop program, it works fine.

When you say you think the problem is with my setup, are you referring to the Cloud or the WD app? 

Thanks for your help.

I thought you already gave up on the WD App since you started talking about a bunch of different apps.

OK.  I tried a different ftp app and got things working.  The secret was to use 192.blah.blah.blah/Public and the iPad can see the files.  I found one app named FTPManager Free that seemed to do most of what I wanted which is picture slideshows and play music.  The only complaint I have is that I can’t seem to figure out how to get it to play more than one song at a time.  Maybe if I give it a playlist it wil do the trick.

I need to figure out how to use the itunes streaming feature as maybe that will allow it to behave as I would like.  I have also seen that there are DNLA client apps as well but people seem to complain that they are not perfect.

Thanks for your help with a work-around Tony.  Too bad that the WD app does not work.

Maybe the WD app does not work with ios 6 and I need to update to ios 7.