Cant log into but cell phone apps work from Verizon network

I am trying to access my drive i can log in with the apps on my phone which is using veriozn lte . when im on my computer at work i go  to the website and enter in mu user and password and hti submit and it does not do anything does nto even look like it is loading i have tried this on IE,Chrome and firefox with the same resault? Why wont this let me login to web acess?

How can i get this to work? The apps work on my phone but the web access will not work i already forwardered ports on my router and it says its connected and ports are forwarded just used the default?

When i hit sign it , It just sits there like its not even trying to sign in???

Welcome to the Community.

Is JAVA installed in your computer and asking for a security prompt? JAVA is mandatory for remote web access, and it should ask for permissions when attempting to connect. If permissions were denied then you may need to clear your browser’s settings and try again.

I installed Jave but am not getting any kind of prompt when i try and sign in, I went into secureity becuase i read some other guides when i go to control panel choose java secureity it only gives me the option of high and very high there is no medum option. which browser setting do i clear?

My dad also tried to log in from his computer same thing just goes to sign in adn you click sign in and it does not do anything scts like the webpage is dead?

Is there any chance that you have set your browser privacy settings very high or that you are using an ad blocker? The web site uses some form of analytics that can be blocked. AdBlock blocks it.

I ahve the popup blocker tunred off also have the secureity settign clear down to medum on ie no adblock plus or4 anything on here tried 3 diffrrent web browsers, browsers are up to data java is up to date but when i click sign in it does not do antyhing doesnt even try and load the next page, though a ican go into mywd cloud app and wd photos app and access everything on my phone

If you can’t pass the login page it is a web issue on your side or on WD side. If you can pass the login page and see the list of device(s) but you cannot access the shares, it would be a java plugin configuration issue.

So i have logged in with success from 2 other computers at my work i have reset ie disabled all addons removed all java installed current update ive tried chrome firfox ie also downloaded safari and still when i go to wdmycloud i get the login enter my email pass click sign in nothing happins? All these work computers are imaged with the same image i dont get what is causeimg this not to work.

If you take a computer from your work and use it from home, do you observe the same issue? That would point at something between your home connection and the WD servers.

I can sign on and use the my cloud from the online page at home the drive is hooked to my router the other computersvat work same brand same network same firewall rules restrictions they work fine its just what ove noticed a couple computers it has to be some setting im not seeing i work at a antivirus software compony i cinfig firewalls remove virues and troubleshoot computers all day long but i cant figure out this one